hdu 5461 Largest Point (2015 ACM/ICPC Asia Regional Shenyang Online)

点击打开链接

Largest Point

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 474    Accepted Submission(s): 213


Problem Description
Given the sequence  A with  n integers  t1,t2,,tn. Given the integral coefficients  a and  b. The fact that select two elements  ti and  tj of  A and  ij to maximize the value of  at2i+btj, becomes the largest point.
 

Input
An positive integer  T, indicating there are  T test cases.
For each test case, the first line contains three integers corresponding to  n (2n5×106), a (0|a|106) and  b (0|b|106). The second line contains  nintegers  t1,t2,,tn where  0|ti|106 for  1in.

The sum of  n for all cases would not be larger than  5×106.
 

Output
The output contains exactly  T lines.
For each test case, you should output the maximum value of  at2i+btj.
 

Sample Input
 
  
2 3 2 1 1 2 3 5 -1 0 -3 -3 0 3 3
 

Sample Output
 
  
Case #1: 20 Case #2: 0
 

Source

题目大意:有T组数据,然后第一行有三个数n, a, b;

接下来有n行arr[i],求a * arr[i] + b * arr[j] 的最大值(i != j)


解题思路:

分四种情况讨论,有点麻烦,但是却管用,先对arr数组排一下序,

然后在对绝对值数组data排一下序,在判断一下是不是绝对值数组的最值跟原先数组的最值一样,

最后在确定是不是有多个最值就okl



上代码:

/**
2015 - 09 - 20 中午

Author: ITAK

Motto:

今日的我要超越昨日的我,明日的我要胜过今日的我,
以创作出更好的代码为目标,不断地超越自己。
**/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;
typedef long long LL;
const int maxn = 5*1e6+5;
const double eps = 1e-7;
LL arr[maxn], data[maxn];

int main()
{
    int T;
    scanf("%d",&T);
    for(int cas=1; cas<=T; cas++)
    {
        int m, a, b;
        scanf("%d%d%d",&m,&a,&b);
        for(int i=0; i<m; i++)
        {
            scanf("%lld",&arr[i]);
            data[i] = abs(arr[i]);
        }
        sort(data, data+m);
        sort(arr, arr+m);
        LL ans;
        if(a < 0)
        {
            if(b <= 0)
            {
                if(abs(arr[0]) != data[0])
                {
                    ans = data[0]*data[0]*a + arr[0]*b;
                }
                else
                {
                    if(data[0] != data[1])
                        ans = data[0]*data[0]*a + arr[1]*b;
                    else
                        ans = data[0]*data[0]*a + arr[0]*b;
                }
            }
            else
            {
                if(abs(arr[m-1]) != data[0])
                {
                    ans = data[0]*data[0]*a + arr[m-1]*b;
                }
                else
                {
                    if(data[0] != data[1])
                        ans = data[0]*data[0]*a + arr[m-2]*b;
                    else
                        ans = data[0]*data[0]*a + arr[m-1]*b;
                }
            }
        }
        else
        {
            if(b <= 0)
            {
                if(abs(arr[0]) != data[m-1])
                {
                    ans = data[m-1]*data[m-1]*a + arr[0]*b;
                }
                else
                {
                    if(data[m-1] != data[m-2])
                        ans = data[m-1]*data[m-1]*a + arr[1]*b;
                    else
                        ans = data[m-1]*data[m-1]*a + arr[0]*b;
                }
            }
            else
            {
                if(abs(arr[m-1]) != data[m-1])
                {
                    ans = data[m-1]*data[m-1]*a + arr[m-1]*b;
                }
                else
                {
                    if(data[m-1] != data[m-2])
                        ans = data[m-1]*data[m-1]*a + arr[m-2]*b;
                    else
                        ans = data[m-1]*data[m-1]*a + arr[m-1]*b;
                }
            }
        }
        printf("Case #%d: %lld\n",cas, ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值