Largest Point

Largest Point
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
Given the sequence A with n integers t1,t2,,tn . Given the integral coefficients a and b. The fact that select two elements ti and tj of A and ij to maximize the value of at2i+btj , becomes the largest point.

Input
An positive integer T , indicating there are T test cases.
For each test case, the first line contains three integers corresponding to n (2n5×106), a (0|a|106) and b (0|b|106) . The second line contains n integers t1,t2,,tn where 0|ti|106 for 1in .

The sum of n for all cases would not be larger than 5×106.

Output
The output contains exactly T lines.
For each test case, you should output the maximum value of at2i+btj.

Sample Input
2

3 2 1
1 2 3

5 -1 0
-3 -3 0 3 3

Sample Output
Case #1: 20
Case #2: 0

分析:
给你n个数字,从中取两个出来,使 at2i+btj 的值最大。
由于考虑时我们只用考虑最大正数,第二大正数,最小负数,第二小负数,绝对值最小的数,所以我们只需要将这5个数提前找出来,然后慢慢分情况讨论即可。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))

ll T,n,a,b;
ll t[1000010];
ll min1,min2,max1,max2,k;//分别存最小的数、第二小的数、最大的数、第二大的数和最接近0的数

int main ()
{
    scanf ("%lld",&T);
    for (int cas=1; cas<=T; cas++)
    {
        scanf ("%lld%lld%lld",&n,&a,&b);
        k=INF;
        for (int i=0; i<n; i++)
        {
            scanf ("%lld",&t[i]);
        }
        cout<<"Case #"<<cas<<": ";
        sort(t, t+n);
        if(t[0]>0)
            k=t[0];
        else
        {
            for (int i=0; i<n; i++)
            {
                if (t[i]<=0&&t[i+1]>=0)
                    k=min(-t[i], t[i+1]);
            }
        }

        min1=t[0]; min2=t[1];
        max1=t[n-1]; max2=t[n-2];//找出这五个数
        if (a<0&&b<0)//然后就是苦逼的找最大解了,注意负数的平方为正数
        {
            printf ("%lld\n",a*k*k+b*min1);
        }
        else if (a<0&&b>0)
        {
            printf ("%lld\n",a*k*k+b*max1);
        }
        else if (a>=0&&b<0)
        {
            printf ("%lld\n",max(max(a*max1*max1+b*min1, a*min1*min1+b*min2), a*min2*min2+b*min1));
        }
        else if (a>=0&&b>0)
        {
            printf ("%lld\n",max(max(a*max1*max1+b*max2, a*max2*max2+b*max1), a*min1*min1+b*max1));
        }
        else printf ("0\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值