A1023 Have Fun with Numbers (20 分)(大整数乘法模板)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

题意:

给出一个长度不超过20的整数,问这个整数两倍后的数位是否为原数数位的一个排列。

样例解释:

输入1234567899,其中数字1~8均出现一次,9出现两次; 它的两倍为2469135798,其中数字1~8均出现一次,8出现两次。所以第二个数为第一个数的一个排列,输出Yes。

思路:

本题是常规的大整数乘法 - 高精度与低精度数相乘,要对模板理解熟记。

高精度整数与低精度的除法

注意:

  1. 解题中通过change 函数实现了数组的高位对应数字的高位,因此在输出时,也是采用数组下标从高到低输出
#include <cstdio>
#include <cstring>
struct bign{
  int d[21];
  int len;
  bign(){
    memset(d, 0, sizeof(d));
    len = 0;
  }
};
bign change(char str[]){
  bign a;
  a.len = strlen(str);
  for(int i = 0; i < a.len; i++){
    a.d[i] = str[a.len - i - 1] - '0';
  }
  return a;
}
bign multi(bign a, int b){
  bign c;
  int carry = 0;
  for(int i = 0; i < a.len; i++){
    int temp = a.d[i] * b + carry;
    c.d[c.len++] = temp % 10;
    carry = temp / 10;
  }
  while(carry != 0){
    c.d[c.len++] = carry % 10;
    carry /= 10;
  }
  return c;
}
bool Judge(bign a, bign b){
  if(a.len != b.len)
    return false;
  int count[10] = {0};
  for(int i = 0; i < a.len; i++){
    count[a.d[i]]++;
    count[b.d[i]]--;
  }
  for(int i = 0; i < 10; i++){
    if(count[i] != 0){
      return false;
    }
  }
  return true;
}
void print(bign a){
  for(int i = a.len - 1; i >= 0; i--){
    printf("%d", a.d[i]);
  }
}
int main(){
  char str[21];
  scanf("%s", str);
  bign a = change(str);
  bign mul = multi(a, 2);
  if(Judge(a, mul) == true)
    printf("Yes\n");
  else
    printf("No\n");
  print(mul);
  return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值