POJ - 3186 Treats for the Cows


FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:
  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input
Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)
Output
Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input
5
1
3
1
5
2
Sample Output
43
Hint
Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.



题意:

给定n个数,按输入顺序排成一排,每次从外面取一个数,再乘以k(第几个取出的数)。每取一个就总和加上这个值。求最后取完后,总和最大为多少。


思路:

反向思考,相当于往里面加数,先加一个数,其乘以n,接着循环相加左右情况.

代码有具体解释


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f

int s[2005];
long long dp[2005][2005];
int num[2005];

int main(){
	int n;
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
		scanf("%d",&s[i]);
	
	for(int i=1;i<=n;i++)//区间长度为0时 
		dp[i][i]=s[i]*n;//表示第 i 个数最后一个取出 
		//从i=1假设每一个数都是最后一个被取出 ,所以乘以n.
		//接着下面的二层循环区间长度为2开始依次枚举所有数的情况 
	
	
	for(int l=1;l<n;l++){//区间长度 ,从2开始,l=1但是长度为2
		for(int i=1;i+l<=n;i++){//区间开始值 
			int j=i+l;//区间末尾值 
			dp[i][j]=max(dp[i+1][j]+(n-l)*s[i], dp[i][j-1]+(n-l)*s[j]);
			//               右边的进                左边的进 
			//区间由小往大推 
		}
	}
	
	printf("%lld\n",dp[1][n]);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值