POJ 3186 Treats for the Cows 详解 (简单区间DP)

16 篇文章 3 订阅


Treats for the Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5516 Accepted: 2877

Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time. 

The treats are interesting for many reasons:
  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally? 

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2

Sample Output

43

Hint

Explanation of the sample: 

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2). 

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

题意:给出的一系列的数字,可以看成一个双向队列,每次只能从队首或者队尾出队,第n个出队就拿这个数乘以n,最后将和加起来,求最大和

思路:可能会想到贪心。。。每次取最小的,这样不确定性太大了,可能有些小点的,乘以一个大点的次数 > 稍微大一点点的*一个很小的次数。。所以这个没法用脑子或者贪心直接做出来,每一次选择都会影响到后面的,这就是典型的DP了,不能用贪心了。。。仔细思考一下一看就是区间dp,为了不影响后续性,就逆着做,从这个区间什么也没有,到往里加、、、因为如果直接从个数为n的区间做,没法做。。没法往少的转移,不知道去掉哪一个。。。而从小往大转移,就是每个区间由一个比他小1的区间+左面的或者加右面的。。。一想到这就立马反应是区间DP了。。。枚举区间长度跟起点。。。把每个长度所有的状态都枚举出来,初始区间为1很简单,就是这个数乘以n


想到区间dp,就要想到枚举长度然后枚举起点啊。。。。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 2e4;
int a[maxn], dp[maxn][maxn];
int main()
{
    int n;
    while(~scanf("%d", &n))
    {
        for(int i = 1; i <= n; i++)
            scanf("%d", &a[i]), dp[i][i] = a[i]*n; //初始化,区间长度是1的时候,就是最后一个拿的直接乘n
        for(int len = 1; len < n; len++) //枚举区间长度
            for(int i = 1; i < n; i++) //枚举起点
        {
            int j = i + len; //枚举终点
            dp[i][j] = max(dp[i+1][j]+a[i]*(n-len), dp[i][j-1]+a[j]*(n-len)); //每个区间len都由最优区间len-1 +左面或者右面的
        }
        cout << dp[1][n] << endl;
    }
    return 0;
}


  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值