poj#3255Roadblocks

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1…N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R
Lines 2…R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output

Line 1: The length of the second shortest path between node 1 and node N
Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

书上的分析:次短边只有两种情况,1.最短的次短路径更新而成;2.其他最短最短更新。(还是好抽象)

#include<iostream>
#include<cstdio>
#include<vector>
#include<queue>
#include<utility>
#include<algorithm>
using namespace std;
const int INF = 1 << 30;
const int MAXN = 5010;
const int MAXR = 100010;
struct edge{
	int to,cost;
};
vector<edge> es[MAXR * 2];
int n,r,df[MAXN],ds[MAXN];
typedef pair<int,int> P;
priority_queue<P,vector<P>,greater<P> > heap;
int main(){
	int i,c,x,y,d1,d2,v;
	scanf("%d%d",&n,&r);
	for(i = 0;i < r; ++i){
		scanf("%d%d%d",&x,&y,&c);
		edge e;
		e.to = y;
		e.cost = c;
		es[x].push_back(e);
		e.to = x;
		es[y].push_back(e);
	}
	fill(df,df + n + 1,INF);
	fill(ds,ds + n + 1,INF);
	df[1] = 0;
	heap.push(P(0,1));
	while(!heap.empty()){
		P p = heap.top();
		heap.pop();
		d1 = p.first;
		v = p.second;
		if(ds[v] < d1)
			continue;
		for(i = 0;i < es[v].size(); ++i){
			edge& e = es[v][i];
			d2 = d1 + e.cost;//可能由次短路径更新而来
			if(d2 < df[e.to]){
				swap(df[e.to],d2);//可能由未更新的最短路径而来
				heap.push(P(df[e.to],e.to));
			}
			if(d2 < ds[e.to] && d2 > df[e.to]){
				ds[e.to] = d2;
				heap.push(P(d2,e.to));
			}	
		}
	}
	printf("%d",ds[n]);
	return 0;
}

代码思路来自课本。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值