Cisco Packet Tracer网络模拟软件:路由器OSPF动态路由配置


实验目的

掌握OSPF协议的配置方法:
掌握查看通过动态路由协议OSPF学习产生的路由;
熟悉广域网线缆的链接方式;

一、技术原理

OSPF开放式最短路径优先协议,是目前网路中应用最广泛的路由协议之一。属于内部网管路由协议,能够适应各种规模的网络环境,是典型的链路状态协议。OSPF路由协议通过向全网扩散本设备的链路状态信息,使网络中每台设备最终同步一个具有全网链路状态的数据库,然后路由器采用SPF算法,以自己为根,计算到达其他网络的最短路径,最终形成全网路由信息。

二、实验步骤

1.步骤

(1)在本实验中的三层交换机上划分VLAN10、VLAN20 、VLAN30
(2)路由器之间通过V35电缆通过串口连接,DCE端连接在R1上,配置其时钟频率64000。
(3)主机和交换机通过直连线,主机与路由器通过交叉线连接。
(4)在S3560上配置OSPF路由协议。
(5)在路由器R1、R2上配置OSPF路由协议。
(6)将主机默认网关设置为与直连网路设备接口IP地址。
(7)验证主机和服务器之间可以互相同信;

2.实验结构图

实验结构图

3.实验操作过程

PC0:
IP: 192.168.1.2
Submask: 255.255.255.0
Gateway: 192.168.1.1

PC1:
IP: 172.16.1.2
Submask: 255.255.0.0
Gateway: 172.16.1.1

Server:
IP: 192.168.2.2
Submask: 255.255.255.0
Gateway: 192.168.2.1

三层交换机S3560设置

Switch>en
Switch#conf t
//初始化 vlan 端口并绑定物理端口
Switch(config)#vlan 10                              //定义VLAN10
Switch(config-vlan)#exit
Switch(config)#vlan 20                             //定义VLAN20
Switch(config-vlan)#exit
Switch(config)#vlan 30                             //定义VLAN30
Switch(config-vlan)#exit
Switch(config)#interface fa 0/1      
Switch(config-if)#switchport access vlan 10         //VLAN10信任fa 0/1端口
Switch(config-if)#exit
Switch(config)#interface fa 0/2
Switch(config-if)#switchport access vlan 20         //VLAN20信任fa 0/2端口
Switch(config-if)#exit
Switch(config)#interface fa 0/3
Switch(config-if)#switchport access vlan 30         //VLAN30信任fa 0/3端口
Switch(config-if)#exit

//设置vlan端口 ip,子掩码
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.1.1 255.255.255.0   
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 20
Switch(config-if)#ip address 172.16.1.1 255.255.0.0
Switch(config-if)#no shutdown 
Switch(config-if)#exit
Switch(config)#interface vlan 30
Switch(config-if)#ip address 192.168.3.1 255.255.255.0
Switch(config-if)#no shutdown 
Switch(config-if)#exit

路由器R1

Router>en 
Router#conf t

//设置物理端口的IP、子掩码,并开启
Router(config)#interface fa 0/0
Router(config-if)#ip address 192.168.3.4   255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#interface serial 2/0
Router(config-if)#ip address 10.10.10.3    255.0.0.0
Router(config-if)#no shutdown 
Router(config-if)#exit
Router#show ip route

路由器R2

Router>en 
Router#conf t

//设置物理端口的IP、子掩码,并开启
Router(config)#interface fa 0/0
Router(config-if)#ip address 192.168.2.1   255.255.255.0            //服务器一侧
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#interface serial 2/0
Router(config-if)#ip address 10.10.10.4    255.0.0.0
Router(config-if)#no shutdown 
Router(config-if)#exit
Router#show ip route

三层交换机、路由器的ospf转发设置

//三层交换机S3560
Switch#en
Switch#conf t
Switch(config)#no ip domain-loo
Switch(config)#ip routing                                               //开启路由功能
Switch(config)#router ospf 1 
Switch(config-router)#network 192.168.1.0    0.255.255.255  area 0      //宣告相邻网段
Switch(config-router)#network 192.168.3.0    0.255.255.255  area 0  
Switch(config-router)#network 172.16.0.0     0.0.255.255    area 0  
Switch(config-router)#exit
Switch#show ip route

//路由器R1
Router#en
Router#conf t
Router(config)#router ospf 1 
Router(config-router)#network 192.168.3.0     0.0.0.255   area 0        //宣告相邻网段
Router(config-router)#network 10.0.0.0        0.0.0.255   area 0
Router(config-router)#exit
Router#show ip route

//路由器R2
Router#en
Router#conf t
Router(config)#router ospf 1 
Router(config-router)#network 192.168.2.0   0.0.0.255   area 0         //宣告相邻网段
Router(config-router)#network 10.0.0.0      0.0.0.255   area 0
Router(config-router)#exit
Router#show ip route

三、结果验证

1、交换机和路由器输入show IP route后均可显示各网段。
route
2、服务器端ping命令:ping 192.168.1.2和ping172.16.1.2均可ping通
server

  • 2
    点赞
  • 0
    评论
  • 5
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 深蓝海洋 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值