1060 Are They Equal (25分)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10^5 ​with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.
Input Specification:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10^​100​​, and that its total digit number is less than 100.
Output Specification:
For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]…d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.
Note: Simple chopping is assumed without rounding.
Sample Input 1:
3 12300 12358.9

Sample Output 1:
YES 0.123*10^5

Sample Input 2:
3 120 128

Sample Output 2:
NO 0.12010^3 0.12810^3

string不能像数组一样直接进行赋值,如string a, string b, a[i] = b[i]是不行的,只能直接拼接如a += b[i].

#include<iostream>
#include<string>
using namespace std;

int n;  //有效位数

string deal(string s, int &e) {
	int k = 0;  //用于标记s的下标
	while(s.length() > 0 && s[0] == '0') {  //去掉先导零 
		s.erase(s.begin());
	} 
	if(s[0] == '.') { //去掉先导零后为小数点,证明该数小于1 
	    s.erase(s.begin());  //去掉小数点 
		while(s[0] == '0' && s.length() > 0) { //寻找第一个不为零的数 
			s.erase(s.begin());
			--e;  //每去掉一个零,指数-1 
		}
	} else {
		while(s[k] != '.' && k < s.size()) {
			++k; //寻找小数点的位置 
			++e; //只要不是小数点,指数e就++; 
		}
		if(k < s.length()) { //说明存在小数点,并且k记录小数点的位置 
			s.erase(s.begin() + k); //将小数点删除 
		}
	} 
	if(s.length() == 0) {
		e = 0;  //去掉先导零后,字符串长度为0,说明这个数就是0 
	} 
	string res;
	for(int i = 0; i < n; ++i) {
		//string不能像数组一样直接赋值,只能拼接 
		
		if(i < s.size()){
		//在有效位范围内接收s中相应位置的数据,且保证有足够的位数 
		    res += s[i];
			//res[i] = s[i];   
	    } else {  //s所剩的位数不足则添零 
	    	res += '0';
			//res[i] = '0';
		} 
	} 
	
	return res; 
}

int main() {
	string s1, s2;
	cin >> n >> s1 >> s2;
	int e1 = 0, e2 = 0;  //e1, e2分别为s1, s2的指数
	s1 = deal(s1, e1);
	s2 = deal(s2, e2);
	if(s1 == s2 && e1 == e2) {
		cout << "YES " << "0." << s1 << "*10^" << e1; 
	} else {
		cout << "NO " << "0." << s1 << "*10^" << e1 << " ";
		cout  << "0." << s2 << "*10^" << e2 ;
	}
	
	return 0;
}```

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值