HDU - 1045 - Fire Net(dfs )

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

在这里插入图片描述

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.
Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.’ indicating an open space and an uppercase ‘X’ indicating a wall. There are no spaces in the input file.
Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
Sample Input
4
.X…

XX…

2
XX
.X
3
.X.
X.X
.X.
3

.XX
.XX
4




0
Sample Output
5
1
5
2
4
题目链接
参考题解
这里选用了dfs算法,其实还可以用二分图的最大分配,但是暂时还没弄懂,就先记一下dfs。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
char mp[5][5];
int dx[4] = {0, 0, 1, -1};
int dy[4] = {1, -1, 0, 0};
int ans_max = 0, n;

bool set_down(int x, int y)
{
    for(int i = x; i >= 0; i--) //行上检查能不能放
    {
        if(mp[i][y] == 'X')
            break ;
        if(mp[i][y] == 'B')
            return false;
    }

    for(int i = y; i >= 0; i--) //列上检查能不能放
    {
        if(mp[x][i] == 'X')
            break ;
        if(mp[x][i] == 'B')
            return false;
    }
    return true;
}

void dfs(int pos, int sum)
{
    int x = pos / n;    //行数
    int y = pos % n;    //列数
    if(pos == n * n)    //整个图已经遍历完成,能建造更多炮台时,更新答案
    {
        if(sum > ans_max)   ans_max = sum;
        return ;
    }
    if(mp[x][y] == '.' && set_down(x, y))   //能建炮台
    {
        mp[x][y] = 'B';
        dfs(pos + 1, sum + 1);
        mp[x][y] = '.';
    }
    dfs(pos + 1, sum);  //不能建炮台
}

int main()
{
    while(scanf("%d", &n), n)
    {
        ans_max = 0;
        for(int i = 0; i < n; i++)
        {
            getchar();
            scanf("%s", mp[i]);
        }
        dfs(0, 0);
        printf("%d\n", ans_max);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值