CGL_2_D——Distance(求两线段距离)

Distance

 

For given two segments s1 and s2, print the distance between them.

s1 is formed by end points p0 and p1, and s2 is formed by end points p2 and p3.

Input

The entire input looks like:

q (the number of queries)
1st query
2nd query
...
qth query

Each query consists of integer coordinates of end points of s1 and s2 in the following format:

xp0 yp0 xp1 yp1 xp2 yp2 xp3 yp3

Output

For each query, print the distance. The output values should be in a decimal fraction with an error less than 0.00000001.

Constraints

  • 1 ≤ q ≤ 1000
  • -10000 ≤ xpi, ypi ≤ 10000
  • p0≠p1 and p2≠p3.

Sample Input

3
0 0 1 0 0 1 1 1
0 0 1 0 2 1 1 2
-1 0 1 0 0 1 0 -1

Sample Output

1.0000000000
1.4142135624
0.0000000000

题目链接:http://judge.u-aizu.ac.jp/onlinejudge/description.jsp?id=CGL_2_D

#include<bits/stdc++.h>
using namespace std;
typedef complex<double> qua;
const double epx=1e-7;
int ccw(qua a,qua b,qua c)
{
    b-=a,c-=a,a=c*conj(b);
    if(a.imag()>epx) return 1;
    if(a.imag()<-epx) return -1;
    if(a.real()<-epx) return 2;
    if(abs(b)+epx<abs(c)) return -2;
    return 0;
}
int isintersect(qua a,qua b,qua c,qua d)
{
    return (ccw(a,b,c)*ccw(a,b,d)<=0)&&(ccw(c,d,a)*ccw(c,d,b)<=0);
}
double dot(qua a,qua b)
{
    return real(b*conj(a));
}
double cross(qua a,qua b)
{
    return imag(b*conj(a));
}
double dist(qua a,qua b,qua c)
{
    if(dot(b-a,c-a)<0) return abs(c-a);
    if(dot(a-b,c-b)<0) return abs(c-b);
    return abs(cross(b-a,c-a))/abs(b-a);
}
double dist(qua a,qua b,qua c,qua d)
{
    if(isintersect(a,b,c,d)) return 0;
    double ab=min(dist(a,b,c),dist(a,b,d));
    double cd=min(dist(c,d,a),dist(c,d,b));
    return min(ab,cd);
}
int main()
{
    int t ;
    double x1,x2,x3,x4,y1,y2,y3,y4;
    for(scanf("%d",&t);t;--t)
    {
        scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3,&x4,&y4);
        printf("%.12f\n",dist(qua(x1,y1),qua(x2,y2),qua(x3,y3),qua(x4,y4)));
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值