POJ 1306 Combinations

描述

Computing the exact number of ways that N things can be taken M at a time can be a great challenge when N and/or M become very large. Challenges are the stuff of contests. Therefore, you are to make just such a computation given the following: 
GIVEN: 5 <= N <= 100; 5 <= M <= 100; M <= N
Compute the EXACT value of: C = N! / (N-M)!M!
You may assume that the final value of C will fit in a 32-bit Pascal LongInt or a C long. For the record, the exact value of 100! is: 
93,326,215,443,944,152,681,699,238,856,266,700,490,715,968,264,381,621, 468,592,963,895,217,599,993,229,915,608,941,463,976,156,518,286,253, 697,920,827,223,758,251,185,210,916,864,000,000,000,000,000,000,000,000

输入

The input to this program will be one or more lines each containing zero or more leading spaces, a value for N, one or more spaces, and a value for M. The last line of the input file will contain a dummy N, M pair with both values equal to zero. Your program should terminate when this line is read.

输出

The output from this program should be in the form: 
N things taken M at a time is C exactly. 

样例输入

100  6
20  5
18  6
0  0

样例输出

100 things taken 6 at a time is 1192052400 exactly.
20 things taken 5 at a time is 15504 exactly.
18 things taken 6 at a time is 18564 exactly.
这道题我重新认识了一下各个数据类型所能表示的数据范围

double  表示范围: -1.7e+308 ~ 1.7e+308

long double 表示范围: -3.4e+4932 ~ 3.4e+4932
组合数: 从n个数据中选出m个数据 Cnm
Cnm = C(n-1)m + C(n-1)(m-1)
#include<iostream>
using namespace std;
const int N = 1e9 + 7;

double c[110][110];

void init(){
    
    for (int i = 1 ; i <= 109; ++i)
        for (int j = 0; j <= i; ++j){
            if (j == 0 || j == i)
                c[j][i] = 1;
            else
                c[j][i] = (c[j][i - 1] + c[j - 1][i - 1]);
        }
}

int main(){
    init();
    int n,x,y;
    while(scanf("%d%d",&x,&y)){
        if (x == 0 && y == 0) break;
        //100 things taken 6 at a time is 1192052400 exactly.
        printf("%d%s%d%s%.0f%s\n",x," things taken ",y," at a time is ",c[y][x]," exactly.");
    }
    return 0;
}

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值