poj 1306 Combinations



正在学Java 

第一次用Java做题好兴奋啊认识了Java中的大数用法,其实我预习预习应该自己懂这些函数的

也熟悉下Java提交的套路

参考了网址

https://xuanwo.org/2014/07/18/POJ-1306-Combinations/

Combinations
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%lld & %llu

Description

Computing the exact number of ways that N things can be taken M at a time can be a great challenge when N and/or M become very large. Challenges are the stuff of contests. Therefore, you are to make just such a computation given the following: 
GIVEN: 5 <= N <= 100; 5 <= M <= 100; M <= N 
Compute the EXACT value of: C = N! / (N-M)!M! 
You may assume that the final value of C will fit in a 32-bit Pascal LongInt or a C long. For the record, the exact value of 100! is: 
93,326,215,443,944,152,681,699,238,856,266,700,490,715,968,264,381,621, 468,592,963,895,217,599,993,229,915,608,941,463,976,156,518,286,253, 697,920,827,223,758,251,185,210,916,864,000,000,000,000,000,000,000,000 

Input

The input to this program will be one or more lines each containing zero or more leading spaces, a value for N, one or more spaces, and a value for M. The last line of the input file will contain a dummy N, M pair with both values equal to zero. Your program should terminate when this line is read.

Output

The output from this program should be in the form: 
N things taken M at a time is C exactly. 

Sample Input

100  6
20  5
18  6
0  0

Sample Output

100 things taken 6 at a time is 1192052400 exactly.
20 things taken 5 at a time is 15504 exactly.
18 things taken 6 at a time is 18564 exactly.
import java.math.*;
import java.util.*;
public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		  Scanner cin=new Scanner(System.in);
		  while(true){
			  int a=cin.nextInt();
	            int b=cin.nextInt();
	            if(a==0 && b==0)
	                return;
	            BigInteger fir=factor(a);
	            BigInteger sec=factor(a-b);
	            BigInteger third=factor(b);
	            BigInteger result=fir.divide(sec).divide(third);
	            System.out.println(a+" things taken "+b+" at a time is "+result.toString()+" exactly.");
	        }
	}


public static BigInteger factor(int n)
{
	BigInteger goal=BigInteger.ONE;
	for(int i=n;i>=2;i--)
	{
		goal=goal.multiply(new BigInteger(String.valueOf(i)));
	}
	return goal;
}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值