POJ - 3904 容斥原理

题目链接

Stancu likes space travels but he is a poor software developer and will never be able to buy his own spacecraft. That is why he is preparing to steal the spacecraft of Petru. There is only one problem – Petru has locked the spacecraft with a sophisticated cryptosystem based on the ID numbers of the stars from the Milky Way Galaxy. For breaking the system Stancu has to check each subset of four stars such that the only common divisor of their numbers is 1. Nasty, isn’t it? Fortunately, Stancu has succeeded to limit the number of the interesting stars to N but, any way, the possible subsets of four stars can be too many. Help him to find their number and to decide if there is a chance to break the system.

Input

In the input file several test cases are given. For each test case on the first line the number N of interesting stars is given (1 ≤ N ≤ 10000). The second line of the test case contains the list of ID numbers of the interesting stars, separated by spaces. Each ID is a positive integer which is no greater than 10000. The input data terminate with the end of file.

Output

For each test case the program should print one line with the number of subsets with the asked property.

Sample Input

4
2 3 4 5 
4
2 4 6 8 
7
2 3 4 5 7 6 8

Sample Output

1 
0 
34
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <iostream>
#include <map>
#include <vector>
#include <queue>
#include <set>
#define eps 1e-8
typedef long long ll;
const double PI = acos(-1.0);
const int maxn = 1e6;
const int INF = 1e9;
const ll linf = 0x3f3f3f3f3f3f3f3f;
using namespace std;
ll n,x;
ll a[maxn];
//fac中记录数字被分解出的质因数
//cnt[i]含因子i的给定数的个数
//num[i]i中包含多少个素因子
ll cnt[maxn],num[maxn],fac[maxn];
ll cal(ll x)
{
        return x*(x-1)*(x-2)*(x-3)/24;
}
int Div(ll x)
{
    int ct = 0;
    for(int i = 2; i*i<=x; i++)
    {
        if(x%i == 0)
        {
            fac[ct++] = i;
            while(x%i == 0)
                x /= i;
        }
    }
    if(x != 1)
        fac[ct++] = x;
    return ct;
}

void solve(ll x)
{
    int ct = Div(x);
    for(int i = 1; i<(1<<ct); i++)
    {
        ll tmp = 1;
        ll sum = 0;
        for(int j = 0; j<ct; j++)
        {
            if(i&(1<<j))
            {
                sum++;
                tmp *= fac[j];
            }
        }
        cnt[tmp]++;
        num[tmp] = sum;

    }


}

int main()
{
    while(cin>>n)
    {
        memset(cnt, 0 ,sizeof cnt);
        for(int i = 0; i<n; i++)
        {
            cin>>x;
            solve(x);
        }
        ll ans  = 0;
        for(int i = 0; i<=10000; i++)
        {
            if(cnt[i])
            {
                if(num[i]&1)
                    ans += cal(cnt[i]);
                else
                    ans -= cal(cnt[i]);
            }
        }
        cout<<cal(n)-ans<<endl;
    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值