pat 甲级 图的遍历 连通分量个数 dfs A1021 Deepest Root (25分)

21 篇文章 0 订阅
10 篇文章 0 订阅

1021 Deepest Root (25分)

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

 题意:给出n个结点(1~n)之间的n条边,问是否能构成一棵树,如果不能构成则输出它有的连通分量个数,如果能构成一棵树,输出能构成最深的树的高度时,树的根结点。如果有多个,按照从小到大输出。

#include<iostream>
#include<set>
#include<vector>
#include<algorithm>
using namespace std;
vector<vector<int>> v;
set<int> s;
vector<int> temp;
bool flag[10010];
int n;
int maxHight=0;
void dfs(int a,int hight)
{
    flag[a]=true;
    if(hight>maxHight){
        temp.clear();
        temp.push_back(a);
        maxHight=hight;
    }
    else if(hight==maxHight)
        temp.push_back(a);
    for(int i=0;i<v[a].size();i++){
        if(flag[v[a][i]]==false){
            dfs(v[a][i],hight+1);
        }
    }
}
int main()
{
    int n1,n2,s1,ans=0;
    cin>>n;
    v.resize(n+1);
    temp.resize(n+1);
    for(int i=0;i<n-1;i++){
        cin>>n1>>n2;
        v[n1].push_back(n2);
        v[n2].push_back(n1);
    }
    for(int i=1;i<=n;i++){
        if(flag[i]==false){//标记已访问结点
            dfs(i,1);
            if(i==1){
                if(temp.size()!=0) s1=temp[0];
                for(int j=0;j<temp.size();j++)
                    s.insert(temp[j]);
            }
            ans++;//连通分量个数
        }
    }
    if(ans>1) printf("Error: %d components\n",ans);
    else{//就只有一个连通分量 可以够成树
        maxHight=0;
        fill(flag,flag+10010,false);
        dfs(s1,1);//任意选取1个第一次dfs得到最高高度的结点们,从此结点出发重新再次dfs,这两个结点集合的并集(set容器会自动去重)就是所求所有最高高度的根结点
        for(int i=0;i<temp.size();i++)
            s.insert(temp[i]);
        for(auto it:s)
            cout<<it<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值