PAT甲级——A1023 Have Fun with Numbers

题目

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

Solution:

问,一个数的double后,是不是还是由原来的数字组成的?
说白了就是问,一个数加上自己是不是自己的一个排列?

使用nums[10]来记录原来的数的各个数字出现的次数,然后与其和对比
或者直接排序后对比是不是一样的
注意:大数运算, 用字符实现加减

Code


#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
int main()
{
	string s1, s2, s3;
	cin >> s1;
	s2 = s1;
	int temp, index = 0;
	for (int i = s1.length()-1; i >= 0; i--)
	{
		temp = s1[i] - '0' + s1[i] - '0' + index;
		s2[i] = temp % 10 + '0';
		index = temp / 10;
	}
	if (index > 0)
		s2.insert(s2.begin(), index + '0');
	s3 = s2;
	sort(s1.begin(), s1.end());
	sort(s2.begin(), s2.end());
	if (index > 0 || s1 != s2)
		cout << "No" << endl;
	else
		cout << "Yes" << endl;
	cout << s3 << endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值