hdu1796 How many integers can you find (容斥原理)

Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output
  For each case, output the number.
 

Sample Input
  
  
12 2 2 3
 

Sample Output
  
  
7
 

Author
wangye

题意:
问有多少个小于n的数能被集合里的数整除。集合拥有m个元素。
自己写的DFS容斥, 写得很粗糙, 在求最大公因数的时候没有用long long ,爆了int, 无情wa,于是破罐子破摔把所有的int都改成 long long就过了。后面附上大神代码, 十分精简

#include<iostream>
#include<cstdio>
#include<algorithm>
#define ll long long
using namespace std;
int n, m, num[15];
long long  sum, gg;
int cmp(int k1, int k2)  
{   int a = max(k1, k2);
    int b = min(k1, k2);
    
    if(b == 0) return a;
	
	int temp;
    while(b != 0)  
    {  
        temp = a % b;  
        a = b;  
        b = temp;  
    }  
    
    return (1LL * k1 * k2) / a ;
  
}  
ll ans(int x){
	if(x == 0) return 0;
	ll te = n / x, mod = n % x;
	if(mod == 0) 
	 return te - 1;
	 
	return te;
} 
void DFS(int po, int te, int n, int co){  
    int cc = te;
	if(n == co){
	  //cout<<ans(te)<<endl;
      gg +=ans(te);
     // cout<<"te="<<te<<endl;
      //cout<<gg<<endl;
    } 
    for(int i = 1; (po + i) < m; i++){
        te = cmp(cc,num[po + i]);
		DFS(po + i, te, n + 1, co);
	}
   
} 
int main(){
	while(scanf("%d", &n) != EOF){
		 scanf("%d", &m);
		for(int i = 0; i < m; i++){
			scanf("%d", num + i);
			
			if(num[i] == 0){
			  i--;
			  m--;	
			}
		}
	    sum = 0; 
		int f = -1;
		for(int co = 1; co <= m; co++) 
		{
			 f *= -1; 
			for(int i = 0; i < m; i++){
				     gg = 0;
		    		 DFS(i, num[i], 1, co);   
		    	     sum+= f * gg;
		    	    
			}
			
		}
	  cout<<sum<<endl;	
	
		    
	}
	return 0;
}

附上大神代码


#include<iostream>
#include<cstdio>
#include<algorithm>
#define ll long long
using namespace std;
ll ans;
int n, m, num[15];
int gcd(ll a, ll b){
	return b == 0 ? a : gcd(b, a % b);
} 
void DFS(int cur, ll lcm, int vis){
   lcm = num[cur] / gcd( num[cur], lcm) * lcm;
   if(vis % 2)
        ans += (n - 1) / lcm;
   else  
       ans -= (n - 1) / lcm;
       
    for(int i = cur + 1; i < m; i++)
        DFS(i, lcm, vis + 1);
}

int main(){
	while(scanf("%d%d", &n, &m) != EOF){
		for(int i = 0; i < m; i++){
			scanf("%d", num + i);
			if(num[i] == 0)
			   i-- , m--; 
		}
		ans = 0;
		for(int i = 0; i < m ; i++){
			DFS(i, num[i], 1);
		}
		cout<<ans<<endl;
	}
	

		    
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Blaze Jack

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值