1064 Complete Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

思路:

根据输入的键值构造一颗完全二叉树,二叉树中序遍历为非递减序列
输入n,n个结点的完全二叉树是确定的,因此可以直接构造出树的形态,此时所有结点的键值未知。对输入的n个键值进行排序,随后对构造好的树进行中序遍历,把排序好的键值依次填入访问到的结点中,即完成完全二叉树的构建。
最后顺序输出树结点键值(顺序存储的完全二叉树层序遍历即为顺序输出)。

源码:

#include<bits/stdc++.h>
#define Max 2000
using namespace std;
typedef struct node{
    int key;
    int left;
    int right;
}*Tree;
int t[Max];
int cnt=0;
void in_order(int s,Tree T)
{
	//中序遍历树结构,把排序好的键值填入访问到的结点
    if(T[s].left!=-1)
        in_order(T[s].left,T);
    T[s].key=t[cnt++];
    if(T[s].right!=-1)
        in_order(T[s].right,T);
}
int main()
{
    int n;cin>>n;
    Tree T=(Tree)malloc(sizeof(struct node)*n);
    for(int i=0;i<n;i++)
    {
        cin>>t[i];
        //构建树结构
        T[i].left=2*i+1<n?2*i+1:-1;
        T[i].right=2*i+2<n?2*i+2:-1;
    }
	//键值排序
    sort(t,t+n);
    //中序遍历
    in_order(0,T);
	//顺序输出
    cout<<T[0].key;
    for(int i=1;i<n;i++)
        cout<<" "<<T[i].key;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值