1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: , where K is the number of nonzero terms in the polynomial, and are the exponents and coefficients, respectively. It is given that .

Output

For each test case, you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

思路:

用map就可以,map默认按less对key做升序排序,把less改为greater.
当value==0,系数为0,则把这个键值对清除。
最后顺序输出。

源码:

#include<bits/stdc++.h>
using namespace std;
map<int,double,greater<int> > mp;
int main()
{
	int k;int n=2;
	while(n--)
	{
		cin>>k;
		for(int i=0;i<k;i++)
		{
			int ex;double co;
			cin>>ex>>co;
			mp[ex]+=co;
			if(mp[ex]==0)
				mp.erase(ex);
		}
	}
	cout<<mp.size();
	for(map<int,double>::iterator it=mp.begin();it!=mp.end();it++)
	{
		cout<<" "<<it->first;
		printf(" %.1lf",it->second);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值