1021 Deepest Root (25分)

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes’ numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

思路:

采用并查集+BFS的方法,并查集用于判断图是否连通,若连通则用n次BFS找出根。
不知道为啥不是超时就是超内存。。。代码有错以后再看吧(今天偷个懒)

#include<bits/stdc++.h>

#define Max 10001
#define inf 99999
using namespace std;
vector<int> broot;
int bh = -1;
queue<int> que;
int n;
int num;//集合数,用于判断是否连通
int find(int x, int *parent) {
    if (parent[x] < 0)return x;
    else {
        return parent[x] = find(parent[x], parent);
    }
}

void Union(int a, int b, int *parent) {
    int pa, pb;
    pa = find(a, parent);
    pb = find(b, parent);
    if (pa != pb) {
        num--;//集合数-1
        if (parent[pa] <= parent[pb]) {
            parent[pa] += parent[pb];
            parent[pb] = pa;
        } else {
            parent[pb] += parent[pa];
            parent[pa] = pb;
        }
    }
}

int main() {
    cin >> n;
    num=n;
    bool vis[n + 1];
    int parent[n + 1];
    vector<int> g[n+1];
    fill(parent, parent + n + 1, -1);
    for (int i = 0; i < n - 1; i++) {
        int a, b;
        scanf("%d %d", &a, &b);
        g[a].push_back(b);
        g[b].push_back(a);
        Union(a, b, parent);
    }
    if (num!=1)
        printf("Error: %d components", num);
    else {
        for (int i = 1; i <= n; i++) {
            que.push(i);
            que.push(-1);
            int height = 0;
            fill(vis, vis + n + 1, false);
            while (!que.empty()) {
                int t = que.front();
                que.pop();
                if (t == -1) {
                    height++;
                    if (que.size() != 0)
                        que.push(-1);
                } else {
                    vis[t] = true;
                    for (int i = 1; i <= n; i++) {
                        if ((find(g[i].begin(),g[i].end(),t)!=g[i].end()) && !vis[i])
                            que.push(i);
                    }
                }
            }
            if (height > bh) {
                bh = height;
                broot.clear();
                broot.push_back(i);
            } else if (height == bh)
                broot.push_back(i);
        }
        for (auto it = broot.begin(); it != broot.end(); it++)
            printf("%d\n", *it);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值