1025 PAT Ranking (25分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

结构体排序,简单题
每次按照一个机房先排一次,确定location_rank,最后再总地排序一次确定final_rank,输出

源码:

#include<bits/stdc++.h>

#define Max 30010
using namespace std;
typedef struct student {
    string id;//考号
    int score;//分数
    int loc;//本地号
    int fk;//最终排名
    int lk;//本地排名
} st;
st pp[Max];
int n, k, cnt = 0;//总人数
int last = 0;//局部人数开头索引

bool compare1(st a, st b) {//用于局部排序
    return a.score > b.score;
}

bool compare2(st a, st b) {//用于总排序
    if (a.score != b.score)
        return a.score > b.score;//主要关键词为成绩
    else
        return a.id < b.id;//次要关键字为id号
}

int main() {
    cin >> n;
    for (int i = 0; i < n; i++) {
        scanf("%d", &k);
        for (int j = 0; j < k; j++) {
            char id[15];
            int score;
            getchar();
            scanf("%s%d", id, &score);
            st t;
            t.id = id;
            t.loc = i + 1;
            t.score = score;
            pp[cnt++] = t;
        }
        sort(pp + last, pp + cnt, compare1);//每一个机房成绩读入完毕进行一次局部排序
        for (int i = last; i < cnt; i++) {
            if (i != last && pp[i].score == pp[i - 1].score)
                pp[i].lk = pp[i - 1].lk;
            else
                pp[i].lk = i - last + 1;
        }
        last = cnt;//更新last
    }
    cout << cnt << endl;
    sort(pp, pp + cnt, compare2);//总排序确定最终排名
    for (int i = 0; i < cnt; i++) {
        if (i != 0 && pp[i].score == pp[i - 1].score)
            pp[i].fk = pp[i - 1].fk;
        else
            pp[i].fk = i + 1;

        printf("%s %d %d %d\n", pp[i].id.c_str(), pp[i].fk, pp[i].loc, pp[i].lk);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值