GZHU18级寒假训练:Virgo's Trial-I

UVA-10020(贪心)

  • Given several segments of line (int the X axis) with coordinates [Li , Ri ]. You are to choose the minimal amount of them, such they would completely cover the segment [0, M].
  • Input
    The first line is the number of test cases, followed by a blank line.
    Each test case in the input should contains an integer M (1 ≤ M ≤ 5000), followed by pairs “Li Ri” (|Li |, |Ri | ≤ 50000, i ≤ 100000), each on a separate line. Each test case of input is terminated by pair ‘0 0’.
    Each test case will be separated by a single line.
  • Output
    For each test case, in the first line of output your programm should print the minimal number of line
    segments which can cover segment [0, M]. In the following lines, the coordinates of segments, sorted
    by their left end (Li), should be printed in the same format as in the input. Pair ‘0 0’ should not be
    printed. If [0, M] can not be covered by given line segments, your programm should print ‘0’ (without
    quotes).
    Print a blank line between the outputs for two consecutive test cases.
  • Sample Input
    2
    1
    -1 0
    -5 -3
    2 5
    0 0
    1
    -1 0
    0 1
    0 0
  • Sample Output
    0
    1
    0 1

题意:给出了一些数轴上的范围[L,R]和m,问这些范围在数轴上是否能完全覆盖[0,m]这个范围,如果可以输出最小需要几个范围可以覆盖,把他们按左范围排序输出。

  • 贪心算法。

#include<iostream>
using namespace std;


vector<pair<int,int> >v,ans;

bool cmp(pair<int,int> p1,pair<int,int>p2)
{
    return p1.second>p2.second;
}
int main()
{
   int T;
   while(cin>>T)
   {
       while(T--)
       {
           v.clear();
           ans.clear();
           int n;
           cin>>n;
           int l,r;
           while(cin>>l>>r&&(l||r))
           {
               if(!(r<=0||l>=n))
               v.push_back(make_pair(l,r));
           }
           sort(v.begin(),v.end(),cmp);
           int now=0;
           while(now<n)
           {
               bool flag=false;
               for(int i=0;i<v.size();i++)
               {
                   if(v[i].first<=now&&v[i].second>now)
                   {
                       ans.push_back(v[i]);
 
                       now=v[i].second;
                       v.erase(v.begin()+i);
                       flag=true;
                       i--;
                   }
               }
               if(!flag)
                break;
           }
           if(T)
            cout<<endl;
           if(now>=n)
           {
               cout<<ans.size()<<endl;
               for(int i=0;i<ans.size();i++)
               {
                   cout<<ans[i].first<<' '<<ans[i].second<<endl;
               }
           }
           else
           {
               cout<<0<<endl;
           }
       }
   }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值