杭电OJ之1003 MAX SUM.

Problem Description
Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

#include<stdio.h>
int main(void)
{
int t, n, a[100000],sum,max_sum;
int i, j,start,end,temp;
//用sum,和temp暂时储存起,条件成立进行更新
scanf("%d", &t);
for (i = 0; i < t; i++)
{
scanf("%d", &n);
for (j = 0; j < n; j++)
scanf("%d", &a[j]);
max_sum = a[0];
for (j = 0,temp=0,sum=0,end=0,start=0; j < n; j++)
//把前j项加起来与max_sum比较,如果sum大于max sum,进入更新起始位置后最终位置。
{
sum += a[j];
if (sum > max_sum)
{
max_sum = sum;
start = temp;
end = j;
}
if (sum < 0)//如果sum小于零,丢弃j前面的项,继续验证。
{
sum = 0;
temp = j + 1;//用temp储存后来的起始后来的起始位置。
}
}
printf(“Case %d:\n”, i + 1);
printf("%d %d %d\n", max_sum, start+1, end+1);
if (i < t - 1)
printf("\n");
}
return 0;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值