PAT甲级 1008 Elevator

PAT甲级 1008 Elevator

问题描述

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:
For each test case, print the total time on a single line.

Sample Input:
3 2 3 1

Sample Output:
41

题目分析

本题为电梯问题,要求给出电梯将要停的层数,并告知上升一层需6s,下降一层需4s,每层停留5s,问共需要的时间,开始从0层计算。

输入格式:
停下层数总数N 层数1、层数2…层数N

输出格式:
共需要的时间

解决方法:

一个简单的分条件求和问题

#include <iostream>
using namespace std;
int main()
{
    int N;
    cin >> N;
    int floor = 0, total = 0;
    for (int i = 0; i < N; i++)
    {
        int n;
        cin >> n;
        if (n > floor)
        {
            total += (n - floor) * 6 + 5;
            floor = n;
        }
        else if (n < floor)
        {
            total += (floor - n) * 4 + 5;
            floor = n;
        }
        else if (n == floor)
            total += 5;
    }
    cout << total << endl;
    return 0;
}

处理结果:

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值