Catch That Cow(bfs)
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
- Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
- Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
#include<stdio.h>
#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
int vis[100010];
struct node{
int x;
int s;
};
bool checkedge(int x,int k){
if(x<0||x>100000||vis[x]==1)
return 1;
return 0;
}
node bfs(int y,int k){
queue<node>q;
node now,next;
now.x=y;
now.s=0;
vis[now.x]=1;
q.push(now);
while(!q.empty()){
now=q.front();
q.pop();
if(now.x==k)
return now;
int nx;
for(int i=0;i<2;i++){
if(i==0) nx=now.x-1;
if(i==1) nx=now.x+1;
if(checkedge(nx,k))
continue;
next.x=nx;
next.s=now.s+1;
q.push(next);
vis[next.x]=1;
}
nx=now.x*2;
if(checkedge(nx,k)==0){
next.x=nx;
next.s=now.s+1;
q.push(next);
vis[next.x]=1;
}
}
return now;
}
int main(){
int i,j,k,n;
memset(vis,0,sizeof(vis));
cin>>n>>k;
node ans=bfs(n,k);
cout<<ans.s;
return 0;
}