A - Max Sum Plus Plus

Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1 , S 2 , S 3 , S 4 . . . S x , . . . S n ( 1 ≤ x ≤ n ≤ 1 , 000 , 000 , − 32768 ≤ S x ≤ 32767 ) S_1, S_2, S_3, S_4 ... S_x, ... S_n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S_x ≤ 32767) S1,S2,S3,S4...Sx,...Sn(1xn1,000,000,32768Sx32767). We define a function s u m ( i , j ) = S i + . . . + S j ( 1 ≤ i ≤ j ≤ n ) sum(i, j) = S_i + ... + S_j (1 ≤ i ≤ j ≤ n) sum(i,j)=Si+...+Sj(1ijn).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make s u m ( i 1 , j 1 ) + s u m ( i 2 , j 2 ) + s u m ( i 3 , j 3 ) + . . . + s u m ( i m , j m ) sum(i_1, j_1) + sum(i_2, j_2) + sum(i _3, j_ 3) + ... + sum(i _m, j_ m) sum(i1,j1)+sum(i2,j2)+sum(i3,j3)+...+sum(im,jm) maximal ( i x ≤ i y ≤ j x o r i x ≤ j y ≤ j x i_ x ≤ i_ y ≤ j_ x or i_ x ≤ j_ y ≤ j_ x ixiyjxorixjyjx is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of s u m ( i x , j x ) ( 1 ≤ x ≤ m ) sum(i_ x, j_ x)(1 ≤ x ≤ m) sum(ix,jx)(1xm) instead. ^_^

Input

Each test case will begin with two integers m and n, followed by n integers S 1 , S 2 , S 3 . . . S n S _1, S _2, S _3 ... S_ n S1,S2,S3...Sn.
Process to the end of file.

Output

Output the maximal summation described above in one line.

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8

Hint

Huge input, scanf and dynamic programming is recommended.

dp[i][j]表示前j个数分成i组时的最大值
转移方程为dp[i][j] = max(dp[i][j-1] + arr[j], max(dp[i-1][k]) + arr[j]) (0 < k < j)
因为n最大是1e6,所以只能用一维来存储,类似于背包的一维优化。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int N = 1e6 + 5;
const int INF = 0x3f3f3f3f;

int arr[N];
int dp[N];
int ma[N];//当前最大的

int main(void)
{
	int m, n, ans;
	while (scanf("%d%d", &m, &n) != EOF)
	{
		for (int i = 1; i <= n; i++)
			scanf("%d", &arr[i]);
		memset(dp, 0, sizeof(dp));//0个数的全是0
        memset(ma, 0, sizeof(ma));//分成0组的全是0
        for (int i = 1; i <= m; i++)//分成的组数
		{
            ans = -INF;
            for (int j = i; j <= n; j++)//数字个数
			{
				//第j个数分入前一组,第j个数单独成为一组
                dp[j] = max(dp[j-1] + arr[j], ma[j-1] + arr[j]);
                ma[j-1] = ans;
                ans = max(ans, dp[j]);
            }
        }
        printf("%d\n", ans);
	}
	return 0;
}

题解链接:https://blog.csdn.net/codeswarrior/article/details/80310401

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值