D - Constructing Roads(最小生成树)

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

给出所有地方之间的距离,再给出哪些地方之间已经是连通的,再用最小生成树求出最小的建桥长度。
先用ma数组预存一下所有的距离,已经有路的两地之间合并为一个集合即可。

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <cstdio>
using namespace std;
const int N = 2e5;

typedef pair<int, int> P;
int bcj[5005];
int n, m, cnt, ans;
int ma[105][105]; 

struct node {
    int u, v, w;
    inline bool operator < (const node &x) const {
        return w < x.w;
    }
} edge[200005];

int Find(int x)
{
    if(bcj[x] < 0) return x;
    return bcj[x] = Find(bcj[x]);
}

void Union(int x, int y)//合并两个集合
{
    x = Find(x), y = Find(y);//查找两集合的根节点
    if(x == y) return ;
    bcj[x] += bcj[y];//让x成为新集合的根节点
    bcj[y] = x;//让新集合的根节点成为y的根节点
}

void kruskal()
{
    cnt = ans = 0;
    sort(edge, edge + m);
    for(int i = 0; i < m; ++i) {
        int u = Find(edge[i].u), v = Find(edge[i].v);
        if(u == v) continue;
        ans += edge[i].w;
        bcj[v] = u;
        cnt++;
        if(cnt == n - 1) break;   
    }
}

int main()
{
	int t,q;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    	for(int j=1;j<=n;j++)
    	{
    		scanf("%d",&t);
    		ma[i][j]=t;
    	}
	scanf("%d",&q);
	int a,b;
	memset(bcj, -1, sizeof bcj);
	for(int i=0;i<q;i++)
	{
		scanf("%d%d",&a,&b);
		Union(a,b);
	}
	m=0;
    for(int i=1;i<=n;i++) {
        for(int j=i+1;j<=n;j++){
        	edge[m].u=i;edge[m].v=j;
        	edge[m].w=ma[i][j];
        	m++;
        }
    }
    kruskal();
    printf("%d\n", ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值