PAT_A1009 | Product of Polynomials

1009 Product of Polynomials (25分)

This time, you are supposed to find A×BA\times BA×B where AAA and BBB are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

KKK N1N_1N​1​​aN1a_{N_1}a​N​1​​​​N2N_2N​2​​aN2a_{N_2}a​N​2​​​​ ... NKN_KN​K​​aNKa_{N_K}a​N​K​​​​

where KKK is the number of nonzero terms in the polynomial, NiN_iN​i​​ and aNia_{N_i}a​N​i​​​​ (i=1,2,⋯,Ki=1, 2, \cdots , Ki=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤101\le K \le 101≤K≤10, 0≤NK<⋯<N2<N1≤10000 \le N_K < \cdots < N_2 < N_1 \le 10000≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of AAA and BBB in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

 

Sample Output:

3 3 3.6 2 6.0 1 1.6


 可以参考一下这篇文章,一元多项式求和 / 积

下面我是用数组储存直接模拟做的。

代码如下:

//
// Created by LittleCat on 2020/1/26.
//
#include <cstdio>
#define MAX_EXPONENTS 1000

int main() {
    float a[MAX_EXPONENTS + 1] = {0}, b[MAX_EXPONENTS + 1] = {0};
    int k;

    /* 输入第一个多项式 */
    scanf("%d", &k);
    for(int i = 0; i < k; i++) {
        float coefficients;
        int exponents;
        scanf("%d", &exponents);
        scanf("%f", &coefficients);
        a[exponents] += coefficients;
    }

    /* 输入第二个多项式 */
    scanf("%d", &k);
    for(int i = 0; i < k; i++) {
        float coefficients;
        int exponents;
        scanf("%d", &exponents);
        scanf("%f", &coefficients);
        b[exponents] += coefficients;
    }

    float c[2 * MAX_EXPONENTS + 1] = {0};
    for(int i = 0; i <= MAX_EXPONENTS; i++)
        for(int j = 0; j <= MAX_EXPONENTS; j++)
            c[i + j] += a[i] * b[j];

    int num = 0;
    for(int i = 2 * MAX_EXPONENTS; i >= 0; i--)
        if(c[i] != 0)
            num ++;

    printf("%d", num);
    for(int i = 2 * MAX_EXPONENTS; i >= 0; i--)
        if(c[i] != 0)
            printf(" %d %.1f", i, c[i]);
}


end 

欢迎关注个人公众号“鸡翅编程”,这里是认真且乖巧的码农一枚,旨在用心写好每一篇文章,平常会把笔记汇总成推送更新~
 

在这里插入图片描述

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值