PAT练习题 P1014 Waiting in Line (30分) 【队列模拟】


传送门:P1014


P1014 Waiting in Line (30分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (N*M + 1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
Customer​i​ will take T​i
​​ minutes to have his/her transaction processed.
The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window​1​​ while customer​2​​ is served at
window​2. Customer3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​ . Customer​5​​ will wait behind the yellow line.
At 08:01, customer​1​​ is done and customer​5​​ enters the line in front of window​1 ​​ since that line seems shorter now. Customer​2​​ will leave at 08:02, customer​4​​ at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:
For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry


题目大意:
银行排队办理业务,有n个窗口,每个窗口前有黄线,黄线内最多排m个人,剩下的人在黄线外等候。08:00开始办理业务,17:00结束办理业务,如果业务已经开始办理,就继续办理直到办理业务结束窗口才关门。如果某个窗口有人办理业务结束,黄线外的人去那个窗口的队尾等候,如果两个窗口同时有人办理业务结束,就选择窗口号较小的。
给出k个人,并给出他们办理业务所需要的时间,查询 p 个人的办理业务结束间


解题思路:

用队列的入队和出队模拟排队过程,同时计算他们每个人的等待时间。
如果人数比 n*m 小,那么就是直接依次排队,只有当 k > n * m 时 ,每次找到每个窗口(队首)最早处理完的人,使他出队,同时更新后面一个人的等待时间。

特别要注意,最后查询的时候,一定要判断的是这个人的等待时间是否超过了540分钟,如果超过了就输出 sorry



AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<queue>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int N=1e3+10;
int n,m,k,q;
int tim[N];//每个人的处理时间
queue<int> win[30];
int costmin[N];//每个人的总的花费时间

int main()
{
  scanf("%d%d%d%d",&n,&m,&k,&q);
  for(int i=1;i<=k;i++)
  {
    scanf("%d",&costmin[i]);
    tim[i]=costmin[i];
  }
  int t=1;
  while(t<=n*m&&t<=k)
  {
    for(int i=1;i<=n;i++)
    {
      if(!win[i].empty())
      {
        int x=win[i].back();
        costmin[t]+=costmin[x];
      }
      win[i].push(t);
      t++;
    }
  }
  for(;t<=k;t++)
  {
    int tmp=1,minn=costmin[win[1].front()];
    for(int j=2;j<=n;j++)
    {
      int x=win[j].front();
      if(costmin[x]<minn)
      {
        tmp=j;
        minn=costmin[x];
      }
    }
    win[tmp].pop();
    int x=win[tmp].back();
    win[tmp].push(t);
    costmin[t]+=costmin[x];
  }
  while(q--)
  {
    int x;
    scanf("%d",&x);
    int xx=costmin[x];//包括了他自己的花费时间
    if(xx-tim[x]>=540)//结束时间-处理时间=等待时间,等待时间不能大于540分钟
      printf("Sorry\n");
    else
      printf("%02d:%02d\n",(xx+480)/60,xx%60);
  }
  return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据引用,数据结构PAT练习题中包含了关于树的题目。其中有一道题目将二叉树看作图,并对它作图的深度优先遍历,与原二叉树的结果是相同的。答案选项包括前序遍历、中序遍历、后序遍历和层次序遍历。 根据引用和引用,数据结构PAT练习题还包含了测试各种排序算法的题目。这些题目旨在测试不同排序算法在不同数据情况下的表现。测试数据包括只有1个元素、11个不相同的整数、随机整数、顺序整数、逆序整数、基本有序的整数和随机正整数等。 综上所述,数据结构PAT练习题涉及到树的遍历和排序算法的应用。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [数据结构习题-Dijkstra](https://download.csdn.net/download/li_guizhen/2853501)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *2* *3* [数据结构(陈越)PAT练习题 第七周:排序(上)](https://blog.csdn.net/ustcfdm/article/details/43671249)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值