1148 Werewolf - Simple Version (20分)

1148   Werewolf - Simple Version (20分)

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: "Player #2 is a werewolf.";
  • player #2 said: "Player #3 is a human.";
  • player #3 said: "Player #4 is a werewolf.";
  • player #4 said: "Player #5 is a human."; and
  • player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences A=a[1],...,a[M]and B=b[1],...,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

这是乙级的一道题,当时做的时候就没想明白,现在终于想通了,哈哈😄😄~~~~

题目大意:

已知 N 名玩家中有 2 人扮演狼人角色,有 2 人说的不是实话,有狼人撒谎但并不是所有狼人都在撒谎。要求你找出扮演狼人角色的是哪几号玩家?用正号表示好人,负号表示狼人。

如果有解,在一行中按递增顺序输出 2 个狼人的编号,其间以空格分隔,行首尾不得有多余空格。如果解不唯一,则输出最小序列解;若无解则输出 No Solution

解题思路:用 v 数组存储每位玩家说过的话,用 a 数组存储好人和狼人,1 表示好人,-1 表示狼人,用 i 和 j 表示狼人,i 从 1~n,j 从 i+1~n,题目中说有 2 人说谎,设置 lie 数组,从 1~n 分别判断该玩家 k 是否说谎,如果该玩家说的话与实际不符(即 v[k]*a[abs(v[k]) < 0),则该玩家说谎,把该玩家存入 lie 数组中;如果说谎的人数为 2,并且其中一人为好人一人为狼人(题目说有狼人撒谎但并不是所有狼人都在撒谎),就输出 i 和 j ,循环结束;否则,输出 “No Solution”。

AC代码:

#include<iostream>
#include<vector>
#include<cmath>
using namespace std;
int main(){
	int n;
	cin >> n;
	vector<int> v(n+1);
	for(int i = 1; i <= n; i++){
		cin >> v[i];
	}
	for(int i = 1; i <= n; i++){
		for(int j = i+1; j <= n; j++){
			vector<int> lie, a(n+1, 1);
			a[i] = a[j] = -1;
			for(int k = 1; k <= n; k++){
				if(v[k] * a[abs(v[k])] < 0){
					lie.push_back(k);
				}
			}
			if(lie.size()==2 && a[lie[0]]+a[lie[1]] == 0){
				cout << i << " " << j;
				return 0;
			}
		}
	}
	cout << "No Solution";
	return 0;
}

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值