## **PTA-02-线性结构*4 Pop Sequence (25 分) C语言版**

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:
YES
NO
NO
YES
NO

对于一开始学习数据结构的同学来说,大部分都没有学过C++,但大部分题解都是C++写的,所以这道题选择用C来写。
/C语言没有自带的堆栈函数,所以得自己编写,下面列出要用到的操作函数/

 struct Node
    {
    	int Data;
    	struct Node * Next;
    };
    typedef struct Node stack;
    typedef struct Node *Stack;
    Stack  CreatStack ();  /* 构建一个堆栈的头结点,返回该结点指针 */
    int IsEmpty (Stack s) ;/* 判断堆栈S是否为空,若是返回true;否则返回false */
    Pop(Stack s);   /* 删除并返回堆栈S的栈顶元素 */
    Push(Stack s, int Data)  /* 将元素X压入堆栈S */
    int Size(Stack s)    /*返回堆栈的大小*/
    int Top(Stack s)    /*返回栈顶元素*/

Pop Sequence 是2013年PAT春季考试真题,考察队堆栈的基本概念的掌握

#include <stdio.h>
#include <stdlib.h>
struct Node
{
	int Data;
	struct Node * Next;
};
typedef struct Node stack;
typedef struct Node *Stack;
Stack CreatStack()
{
	Stack p;
	p=(Stack)malloc(sizeof(stack));
	p->Next=NULL;
	return p;
}
int IsEmpty(Stack p)
{
	if(p->Next==NULL)
	   return 1;
	else 
	   return 0;   
}
int Pop(Stack p)
{   if(IsEmpty(p))
  {
	printf("栈为空!");
	return 0;
  }
	Stack q;
	int Data;
	q=p->Next;
	Data=q->Data;
	p->Next=q->Next;
	free(q);
	return Data;
}
void Push(Stack p,int Data)
{
	Stack q;
	q=(Stack)malloc(sizeof(stack));
	q->Data=Data;
	q->Next=p->Next;
	p->Next=q;
}
int Size(Stack p)
{
   Stack q;
   q=p;
   int i=0;
   while(q->Next)
    {
    	i++;
    	q=q->Next;
    }
   return i;		
}
int Top(Stack p)
{
	Stack q;
	q=p->Next;
	return q->Data;
}
int main(int argc, char *argv[])
{
	Stack s;
	int M,N,N2,K,i,j,num,flag=1;
	scanf("%d%d%d",&M,&N,&K);
	while(K--)
	{ s=CreatStack(); 
	  N2=N;
	   j=1;
	   flag=1;
	   while(N2--)
	   {   scanf("%d",&num);
		   if(flag)
		   {
	   		  while(IsEmpty(s)||Top(s)!=num)
	   		   {
   		   		  Push(s,j++);
   		   		  if(Size(s)>M)
   		   		   {
   		   		   	flag=0;
   		   		   	break;
   		   		   }
   		   	   }
   		   	  if(Top(s)==num&&Size(s)>=1&&flag)
			 	 Pop(s);	 
	   	   }
	   }
	   if(flag)
        printf("YES\n");
	   else 
	    printf("NO\n");
		free(s);	 
	} 
	return 0;
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Super__Bb

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值