Network(POJ 1144)---割点模板题

题目链接

题目描述

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.
Input

输入格式

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

输出格式

The output contains for each block except the last in the input file one line containing the number of critical places.

输入样例

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

输出样例

1
2

分析

题目大意是给定一个无向图,求这个无向图中的割点数量。
本题直接套用模板即可,只是建图稍微麻烦一点,注意读取数据就ok了。

源程序

tarjan算法

//#include <bits/stdc++.h>
#include <iostream>
#include <cstdio>
#include <cstring>
#define MAXN 105
using namespace std;
struct Edge{
	int v,next;
	Edge(){}
	Edge(int v,int next):v(v),next(next){}
}edge[MAXN*MAXN*2];
int EdgeCount,head[MAXN];
int n,cnt,len;
int dfn[MAXN],low[MAXN],father[MAXN];
bool flag,cut[MAXN]; 
char str[MAXN*MAXN*2];
void addEdge(int u,int v)
{
	edge[++EdgeCount]=Edge(v,head[u]);
	head[u]=EdgeCount;
}
void init()
{
	memset(dfn,0,sizeof(dfn));
	memset(low,0,sizeof(low));
	memset(father,0,sizeof(father));
	memset(head,0,sizeof(head));
	memset(cut,false,sizeof(cut));
	flag=false;
	EdgeCount=cnt=0;
}
void tarjan(int u,int pre)
{
	dfn[u]=low[u]=++cnt;	//时间戳 
	father[u]=pre;	//父节点
	for(int i=head[u];i;i=edge[i].next){
		int v=edge[i].v;
		if(!dfn[v]){	//还未访问过
			tarjan(v,u);
			low[u]=min(low[u],low[v]); 
		}
		else if(pre!=v)	//已被访问过且v不是u的父节点 
			low[u]=min(low[u],dfn[v]); 
	} 
}
int main()
{
	while(~scanf("%d",&n)&&n){
		init();
		while(1){	//建图 
			gets(str);
			len=strlen(str);
			if(str[0]=='0') break;
			int i,u=0,v=0;
			for(i=0;isdigit(str[i]);i++)	//父节点 
				u=u*10+str[i]-'0';
			for(i=i+1;i<=len;i++){	//子节点 
				if(isdigit(str[i]))
					v=v*10+str[i]-'0';
				else{				//建边 
					addEdge(u,v);
					addEdge(v,u);
					v=0;
				}
			}
		}
		tarjan(1,0);
		int root=0;	//根节点数目
		for(int i=2;i<=n;i++){	//标记割点 
			int tmp=father[i];
			if(tmp==1)	//父节点是根节点
				root++;
			else{
				if(low[i]>=dfn[tmp])	//没有返祖边
					cut[tmp]=true; 
			} 
		} 
		if(root>1) cut[1]=true;	//根节点孩子数≥2 
		int ans=0;	//割点数 
		for(int i=1;i<=n;i++)
			if(cut[i])
				ans++;
		cout<<ans<<endl; 
	}
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值