Qin Shi Huang's National Road System(HDU-4081)---次小生成树思想

题目链接

题目描述

During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself “Qin Shi Huang” because “Shi Huang” means “the first emperor” in Chinese.
Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people’s life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.

输入格式

The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.

输出格式

For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.

输入样例

2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40

输出样例

65.00
70.00

分析

题目大意是给出 n 个点的城市坐标与城市的人口,要求将所有城市连通起来,其中有一条道路是魔法道路没有边权,要求这条道路连接的两城市的人口数和为 A,其余道路权值和为 B,求 A/B 的最大值。

对于这道题,我们先求最小生成树,然后通过次小生成树的思想,枚举删边,对于任意一条边<u,v>有两种情况:

  • 对于树边,B=最小生成树-该边
  • 对于非树边,B=最小生成树-dis[u][v],dis[u][v]是两点间最大边的权值。

以下是用Kruskal算法写成的源代码:

源程序

Kruskal算法

#include <bits/stdc++.h>
#define MAXN 1005
#define MAXM MAXN*(MAXN-1)/2
#define INF 0x3f3f3f3f
using namespace std;
struct Pos{
	int x,y,people;
}pos[MAXN];
struct Edge{
	int u,v;
	double w;
	bool operator <(const Edge a)const{
		return w<a.w;
	}
}edge[MAXM];
int t,n,m,father[MAXN];
double dp[MAXN][MAXN];
bool connect[MAXM];
vector<int> g[MAXN];
void init()
{
	memset(connect,false,sizeof(connect));
	memset(dp,0,sizeof(dp));
	for(int i=1;i<=n;i++){
		father[i]=i;
		g[i].clear();
		g[i].push_back(i); 
	}
} 
int find(int x)
{
	if(x==father[x])return x;
	return father[x]=find(father[x]);
}
double kruskal()
{
	int k=0;
	double res=0;
	for(int i=1;i<=m&&k<n-1;i++){
		int u=edge[i].u,v=edge[i].v;
		int fu=find(u),fv=find(v);
		double w=edge[i].w;
		if(fu!=fv){
			res+=w;
			k++;
			father[fu]=fv;
			connect[i]=false;
			int fulen=g[fu].size();
			int fvlen=g[fv].size();
			for(int i=0;i<fulen;i++)
				for(int j=0;j<fvlen;j++)
					dp[g[fu][i]][g[fv][j]]=dp[g[fv][j]][g[fu][i]]=w;
			for(int i=0;i<fulen;i++)
				g[fv].push_back(g[fu][i]);
		}
	}
	return res;
}
double getdis(Pos a,Pos b)
{
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int main()
{
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		init();	//初始化 
		for(int i=1;i<=n;i++)	//读入坐标和人口 
			scanf("%d%d%d",&pos[i].x,&pos[i].y,&pos[i].people);
		m=0;
		for(int i=1;i<=n;i++)	//建图 
			for(int j=i+1;j<=n;j++){
				m++;
				edge[m].u=i,edge[m].v=j;
				edge[m].w=getdis(pos[i],pos[j]);
				connect[m]=true;
			}
		sort(edge+1,edge+m+1);
		double MST=kruskal();	//求最小生成树 
		double res=-INF;
		for(int i=1;i<=m;i++){
			int u=edge[i].u,v=edge[i].v; 
			int sum=pos[u].people+pos[v].people;
			double w=edge[i].w;
			if(!connect[i]){	//对于树边 
				if(sum/(MST-w)>res)
					res=sum/(MST-w);
			}
			else{	//对于非树边 
				if(sum/(MST-dp[u][v])>res)
					res=sum/(MST-dp[u][v]);
			}
		} 
		printf("%.2f\n",res);
	}	
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值