Fire Net(HDU 1045)---行列缩点建图最大匹配数

题目链接

题目描述

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.
A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.
Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.
The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.
The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.
在这里插入图片描述
Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal

输入格式

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.’ indicating an open space and an uppercase ‘X’ indicating a wall. There are no spaces in the input file.

输出格式

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

输入样例

4
.X…

XX…

2
XX
.X
3
.X.
X.X
.X.
3

.XX
.XX
4




0

输出样例

5
1
5
2
4

分析

题目大意是给出有一个 n*n 的图,’.'代表空白区域,'X’代表墙,现在要在空白区域放置结点,要求同一行同一列只能放一个,除非有墙阻隔,问最多能放多少个点。
对于这道题,只有在墙的阻隔情况下,才会出现一行/列出现多个点的情况,那么可以考虑进行缩点,将同一行且没有墙体阻隔的区域缩成一个点,放到左点集中,将同一列且没有墙体阻隔的区域缩成一个点,放到右点集中,从而建成一个二分图,然后求最大匹配即可,以下是bfs和dfs版本的源代码。

源程序

DFS版本

#include <bits/stdc++.h>
#define MAXN 105
using namespace std;
char str[MAXN][MAXN];
int n,col_cnt,row_cnt,link[MAXN];
int col[MAXN][MAXN],row[MAXN][MAXN];
bool g[MAXN][MAXN],vis[MAXN];
bool dfs(int u)
{
	for(int i=row_cnt+1;i<=col_cnt;i++){
		if(g[u][i]&&!vis[i]){	//不在交替路中
			vis[i]=true;
			if(link[i]==-1 || dfs(link[i])){	//未匹配点或找到新匹配 
				link[i]=u;
				return true;
			} 
		}
	}
	return false;
}
int hargarian()
{
	memset(link,-1,sizeof(link));
	int ans=0;	//记录匹配数 
	for(int i=1;i<=row_cnt;i++){	//寻找匹配 
		memset(vis,false,sizeof(vis));
		if(dfs(i))	
			ans++;
	}
	return ans;
}
int main()
{
	while(scanf("%d",&n)&&n){
		memset(col,0,sizeof(col));
		memset(row,0,sizeof(row));
		memset(g,false,sizeof(g));
		for(int i=1;i<=n;i++)
			scanf("%s",&str[i][1]);
		row_cnt=1;
		for(int i=1;i<=n;i++){	//对行缩点 
			for(int j=1;j<=n;j++){
				if(str[i][j]=='.')	//同一区域
					row[i][j]=row_cnt;
				if(str[i][j]=='X')	//墙体阻隔 
					row_cnt++; 
			}
			row_cnt++;	//下一行 
		}
		col_cnt=row_cnt+1;
		for(int j=1;j<=n;j++){	//对行缩点 
			for(int i=1;i<=n;i++){
				if(str[i][j]=='.')	//同一区域
					col[i][j]=col_cnt;
				if(str[i][j]=='X')	//墙体阻隔 
					col_cnt++; 
			}
			col_cnt++;	//下一行 
		}
		for(int i=1;i<=n;i++)	//建图 
			for(int j=1;j<=n;j++)
				if(str[i][j]=='.')
					g[row[i][j]][col[i][j]]=true;	
		printf("%d\n",hargarian()); 
	}
}

BFS版本

#include <bits/stdc++.h>
#define MAXN 105
using namespace std;
char str[MAXN][MAXN];
int n,col_cnt,row_cnt;
int col[MAXN][MAXN],row[MAXN][MAXN];
int pre[MAXN],vis[MAXN],link[MAXN]; 
bool g[MAXN][MAXN];
queue<int> q;
int hargarian()
{
	memset(link,-1,sizeof(link));
	memset(pre,-1,sizeof(pre));
	memset(vis,-1,sizeof(vis));
	int ans=0;	//记录匹配数 
	for(int i=1;i<=row_cnt;i++){	//寻找匹配 
		if(link[i]==-1){	//尚未匹配
			while(!q.empty()) q.pop();
			q.push(i);
			bool flag=false;
			while(!q.empty()&&!flag){	//寻找匹配 
				int u=q.front();q.pop();
				for(int v=row_cnt+1;v<=col_cnt;v++){
					if(!g[u][v]) continue;
					if(flag) break;	//已找到新方案 
					if(vis[v]!=i){	//不在交替路中 
						vis[v]=i;
						if(link[v]>=0)	//对应点已匹配,寻找新方案
							q.push(link[v]),pre[link[v]]=u;
						else{	//找到匹配点 
							flag=true;
							int l=u,r=v;
							while(l!=-1){	//分配新方案 
								int tmp=link[l];
								link[l]=r;
								link[r]=l;
								l=pre[l];
								r=tmp;
							}
						}
					}
				}
			}
			if(link[i]!=-1)	//该点有匹配
				ans++; 
		}
	}
	return ans;
}
int main()
{
	while(scanf("%d",&n)&&n){
		memset(col,0,sizeof(col));
		memset(row,0,sizeof(row));
		memset(g,false,sizeof(g));
		for(int i=1;i<=n;i++)
			scanf("%s",&str[i][1]);
		row_cnt=1;
		for(int i=1;i<=n;i++){	//对行缩点 
			for(int j=1;j<=n;j++){
				if(str[i][j]=='.')	//同一区域
					row[i][j]=row_cnt;
				if(str[i][j]=='X')	//墙体阻隔 
					row_cnt++; 
			}
			row_cnt++;	//下一行 
		}
		col_cnt=row_cnt+1;
		for(int j=1;j<=n;j++){	//对行缩点 
			for(int i=1;i<=n;i++){
				if(str[i][j]=='.')	//同一区域
					col[i][j]=col_cnt;
				if(str[i][j]=='X')	//墙体阻隔 
					col_cnt++; 
			}
			col_cnt++;	//下一行 
		}
		for(int i=1;i<=n;i++)	//建图 
			for(int j=1;j<=n;j++)
				if(str[i][j]=='.')
					g[row[i][j]][col[i][j]]=true;	
		printf("%d\n",hargarian()); 
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值