给定平面上任意三个点的坐标 (x1, y1), (x2, y2), (x3, y3)检验它们能否构成三角形。
输入格式:
输入在一行中顺序给出六个[−100,100]范围内的数字,即三个点的坐标x1,y1,x2,y2,x3,y3
:输出格式:
若这3个点不能构成三角形,则在一行中输出“Impossible”;若可以,则在一行中输出该三角形的周长和面积,格式为“L = 周长, A = 面积”,输出到小数点后2位。
输入样例1:
4 5 6 9 7 8
输出样例1:
L = 10.13, A = 3.00
输入样例2:
4 6 8 12 12 18
输出样例2:
Impossible
#include <stdio.h>
#include <math.h>
int main(void)
{
double x1,y1,x2,y2,x3,y3;
double p;
scanf("%lf %lf %lf %lf %lf %lf", &x1,&y1,&x2,&y2,&x3,&y3);
//可以在这用loop和数组,但是没必要
double l1 = sqrt(pow((x1-x2),2)+pow((y1-y2), 2));
double l2 = sqrt(pow((x1-x3),2)+pow((y1-y3), 2));
double l3 = sqrt(pow((x2-x3),2)+pow((y2-y3), 2));
p = (l1+l2+l3)/2;
//判断是不是三角形,两边之和必须大于第三边
if (l1< l2+l3 && l2<l1+l3 &&l3<l1+l2)
{
printf("L = %.2lf, A = %.2f\n", 2*p, sqrt(p*(p-l1)*(p-l2)*(p-l3)));
}
else printf("Impossible\n");
return 0;
}