滑雪
Time Limit: 1000MS | Memory Limit: 65536K |
---|---|
Description
Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-…-3-2-1更长。事实上,这是最长的一条。
Input
输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。
Output
输出最长区域的长度。
Sample Input
5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
Sample Output
25
题意:一直向下滑,问能滑多远,相邻点距离为1
状态转移方程:
dp[tx][ty]=max(dp[tx][ty], dp[x][y]+1);
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
int r, c, t, ans;
int a[105][105], dp[105][105];
int dir[4][2]= {0,1,0,-1,-1,0,1,0};
struct node
{
int i, j, h;//坐标和高度
}d[10005];
int cmp(node a, node b)
{
return a.h>b.h;
}
int main()
{
while(scanf("%d%d", &r, &c)!=EOF)
{
t=0;
memset(a, 10005, sizeof(a));
for(int i=1; i<=r; i++)
for(int j=1; j<=c; j++)
{
scanf("%d", &a[i][j]);
d[t].i=i, d[t].j=j, d[t++].h=a[i][j];
}
sort(d, d+t, cmp);
int maxx=0;
for(int i=0; i<t; i++)
{
int x=d[i].i, y=d[i].j;
for(int j=0; j<4; j++)
{
int tx=x+dir[j][0], ty=y+dir[j][1];
if(a[x][y]>a[tx][ty])//如果下一步高度较低就可以走
dp[tx][ty]=max(dp[tx][ty], dp[x][y]+1);
}
maxx=max(maxx, dp[x][y]);
}
printf("%d\n", maxx+1);
}
return 0;
}