Find The Multiple(poj 1426)

Find The Multiple

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111

同余模定理简介(https://blog.csdn.net/doneone_/article/details/79721526)
同余模定理:
• (a+b)%c=(a%c+b%c)%c;

• (ab)%c=(a%cb%c)%c;

在这里插入图片描述
枚举前14个数字为:1 、10 、11、100、101、110、111、1000、1001、1010、1011、1100、1101、1110。。。

1110%6=(110*10+0)%6=((110%6)*10)%6+(0%6);

mod[x]=(mod[x/2]*10+x%2)%n;

#include<stdio.h>
int m[1000000];
int main()
{
    int n;
    while(scanf("%d",&n)&&n)
    {
        int ans[200];
        m[1]=1;
        int i;
        for(i=2;m[i-1]!=0;i++)
        {
             m[i]=(m[i/2]*10+i%2)%n;
        }
        i--;int k=0;
        while(i)
        {
            int temp=i%2;
            ans[k]=temp;
            k++;
            i=i/2;
        }
        for(int j=k-1;j>=0;j--)
        {
            printf("%d",ans[j]);
        }
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值