POJ 3663 Costume Party

Costume Party

Time Limit: 1000MS Memory Limit: 65536K

Description

It’s Halloween! Farmer John is taking the cows to a costume party, but unfortunately he only has one costume. The costume fits precisely two cows with a length of S (1 ≤ S ≤ 1,000,000). FJ has N cows (2 ≤ N ≤ 20,000) conveniently numbered 1…N; cow i has length Li (1 ≤ Li ≤ 1,000,000). Two cows can fit into the costume if the sum of their lengths is no greater than the length of the costume. FJ wants to know how many pairs of two distinct cows will fit into the costume.

Input

  • Line 1: Two space-separated integers: N and S
  • Lines 2…N+1: Line i+1 contains a single integer: Li

Output

  • Line 1: A single integer representing the number of pairs of cows FJ can choose. Note that the order of the two cows does not matter.

Sample Input

4 6
3
5
2
1

Sample Output

4

思路:

本题可以直接暴力,也可以用二分查找的方法找到不超过m的下标,然后就可以计算出来最后的总和了。

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 20010;
int main() {
    ios::sync_with_stdio(false);
    int n, sum = 0, m;
    int a[maxn];
    scanf("%d %d", &n, &m);
    for (int i = 0; i < n; i++) scanf("%d", &a[i]);
    sort(a, a + n);
    for (int i = 0; i < n; i++) {
        int x = upper_bound(a + i + 1, a + n, m - a[i]) - a - i - 1;
        if (x == 0) break;
        sum += x;
    }
    printf("%d", sum);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值