1007 Maximum Subsequence Sum (25分)
Given a sequence of K integers { N1, N2, …, NK}. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
心得
这个题说来惭愧,自己想得方法是遍历,准备用暴力搜索。得了15分,有超时,有错误,很垃圾。去网上看了一下网上得思路。在输入得时候直接处理,不断的相加求和,如果之前的数加起来为负数,重新计数,当临时的和大于总和的时候,记录上去。这个里面我存的是数值。有的人写的是索引,其实索引的确更好一点。
错误
暴力搜索费时费力,逻辑还不清晰。应多分析,后做。
#include <iostream>
using namespace std;
int main() {
int K;
int max = -1;
int left = 0;
int right = 0;
cin >> K;
int num[10000] = {0};
bool neg = true;
int temSum=0;
int leftindex=0;
for (int i = 0; i < K; i++)
{
cin >> num[i];
temSum += num[i];
if (temSum > max) {
max = temSum;
left = num[leftindex];
right = num[i];
}
if (temSum < 0) {
temSum = 0;
leftindex = i + 1;
}
if (num[i] >= 0) neg = false;
}
if (neg) {
cout << 0 << " " <<num[0] << " " <<num[K-1];
return 0;
}
cout << max << " "<<left << " " << right;
return 0;
}