1013 Battle Over Cities (25分)
It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city1-city2and city1-city3
. Then if city1is occupied by the enemy, we must have 1 highway repaired, that is the highway city2
-city3
.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input:
3 2 3
1 2
1 3
1 2 3
Sample Output:
1
0
0
心得
这种求最大连通子图的,直接二维vector,然后DFS遍历。去掉该题目说的被占领的城市,该题中只有一个城市被占领,如果多个城市可能就需要先删除城市,再判断了。
添加ios::sync_with_stdio(false)减少输入输出时间。可以不超时。
#include <iostream>
#include <vector>
using namespace std;
vector<vector<int>>path(1001);
int N, M, K;
int geted[1001] = { 0 };
int symbol = 0;
int error;
void DFS(int sym,int city) {
geted[city] = sym;
for (int i = 0; i < path[city].size(); i++)
{
if (geted[path[city][i]] != 0|| path[city][i] == error) continue;
DFS(sym, path[city][i]);
}
}
int dothing(int city) {
for (int i = 0; i < N; i++)
{
if (i == error) continue;
if (geted[i] == 0) {
symbol++;
}
if (geted[i] != 0)continue;
DFS(symbol, i);
}
int max=0;
for (int i = 0; i < N; i++)
{
if (geted[i] > max) {
max = geted[i];
}
}
symbol = 0;
for (int i = 0; i < 1001; i++)
{
geted[i] = 0;
}
return max;
}
int main() {
ios::sync_with_stdio(false);
cin >> N>>M>>K;
for (int i = 0; i < M; i++)
{
int cityOut, cityIn;
cin >> cityIn >> cityOut;
path[cityIn-1].push_back(cityOut-1);
path[cityOut-1].push_back(cityIn-1);
}
for (int i = 0; i < K; i++)
{
int city;
cin >> city;
error = city - 1;
cout<< dothing(city-1)-1<<endl;
}
return 0;
}