报错:tensorboard 1.14.0 has requirement setuptools>=41.0.0, but you'll have setuptools 40.6.3

在用命令行安装tensorflow时遇到如下图所示的报错:
在这里插入图片描述
三个解决办法:
1、检查安装命令是否有误
如图所示我将

pip install tensorflow==1.4

改为了:

pip install tensorflow==1.4.0

更正为了正确的版本号之后问题解决

2、使用强制安装命令

pip install --ignore-installed tensorflow==1.4.0

这里可以记一下强制安装的命令,说不定以后用得着。

3、逐步解决问题再安装
先更新wrapt

pip install --ignore-installed wrapt

再更新setuptools

pip install --ignore-installed  setuptools

最后再使用安装命令:

pip install tensorflow==1.4.0
发布了86 篇原创文章 · 获赞 73 · 访问量 2665
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 书香水墨 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览