Asia 2004, Ehime (Japan), Japan Domestic,杭电1312(DFS,BFS,Queue)

题面参考: https://acm.hdu.edu.cn/showproblem.php?pid=1312
Red and Black
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43036 Accepted Submission(s): 26092
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0
Sample Output
45
59
6
13
题目大意: 在长宽不大于20的图中,’@‘为起始位置为黑色瓷砖,’.'为黑色瓷砖,’#‘为障碍物,从起点出发只能上下左右移动,求图中黑色瓷砖的数量,根据题意使用DFS深度优先搜索或BFS广度优先搜索算法解答。

DFS:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 20;

char mp[maxn][maxn];
int n,m;
int ans = 1;
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
void dfs(int x,int y)
{
	for(int k=0;k<4;k++){
		int dx = x+dir[k][0];
		int dy = y+dir[k][1];
		if(dx<0||dx>=m||dy<0||dy>=n||mp[dx][dy]!='.')continue;
			mp[dx][dy] = '#';
			dfs(dx,dy);
			ans++;
	}
}
int main(void)
{
	int x,y;
	while(~scanf("%d%d",&n,&m),m&&n){
		for(int i=0;i<m;i++){
			for(int j=0;j<n;j++){
				cin>>mp[i][j];
				if(mp[i][j]=='@')x=i,y=j;
			}
		}
		mp[x][y]='#';
		dfs(x,y);
		cout<<ans<<endl;
		ans = 1;
	}
	return 0;
}

BFS:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 20;

char mp[maxn][maxn];
int n,m;
int ans = 1;
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
typedef struct{
	int x,y;
}node;
void bfs(int x,int y)
{
	node start,next;
	start.x = x,start.y = y;
	queue<node>q;
	q.push(start);
	while(!q.empty()){
		start = q.front();
		q.pop();
	for(int k=0;k<4;k++){
		next.x = start.x+dir[k][0];
		next.y = start.y+dir[k][1];
		if(next.x<0||next.x>=m||next.y<0||next.y>=n||mp[next.x][next.y]!='.')continue;
			mp[next.x][next.y] = '#';
			ans++;
			q.push(next);
		}
	}
	
}
int main(void)
{
	int x,y;
	while(~scanf("%d%d",&n,&m),m&&n){
		for(int i=0;i<m;i++){
			for(int j=0;j<n;j++){
				cin>>mp[i][j];
				if(mp[i][j]=='@')x=i,y=j;
			}
		}
		mp[x][y]='#';
		bfs(x,y);
		cout<<ans<<endl;
		ans = 1;
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值