PAT-A1028 List Sorting (多种排序条件)

A1028 List Sorting (多种排序条件)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤105) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 9

Sample Output 3:

000002 James 9
000001 Zoe 60
000007 James 85
000010 Amy 90

题意:

给出学生数和规定的数C,不同的C值对应着不同的排序规则,将学生数按照相应C值的规则排序

分析:

本题不难,主要的易错点(对于我来说)在字典序排序上面,注意还要加上头文件

另外 increasing的意思和non-decreasing一样,都是递增,用<

代码如下:

#include<cstdio>
#include <algorithm>
#include<cstring>
using namespace std;
struct STU{
	int ID;
	char name[10];
	int grade;
}S[100010];
bool cmp1(STU a,STU b){
    return a.ID<b.ID;
}
bool cmp2(STU a,STU b){
	//按照字典序排序
	int s=strcmp(a.name,b.name);
	if(s!=0) return s<0; 
	else return a.ID<b.ID;
}
bool cmp3(STU a,STU b){
	if(a.name==b.name||a.grade==b.grade) return a.ID<b.ID;
	else return a.grade<b.grade;
}
int main(){
	int m,n;
	scanf("%d %d",&m,&n);
	for(int i=0;i<m;i++){
		scanf("%d %s %d",&S[i].ID,&S[i].name,&S[i].grade);
	}
	if(n==1) sort(S,S+m,cmp1);
	else if(n==2) sort(S,S+m,cmp2);
	else sort(S,S+m,cmp3);
	for(int i=0;i<m;i++){
		printf("%06d %s %d\n",S[i].ID,S[i].name,S[i].grade);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值