PAT-A1041 Be Unique

A1041 Be Unique

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

结尾无空行

Sample Output 1:

31

结尾无空行

Sample Input 2:

5 888 666 666 888 888

结尾无空行

Sample Output 2:

None

结尾无空行

如果双层嵌套循环的话,时间复杂度为O(n^2),又有一个测试点因为超时而无法通过,如果用HashTable的话可以极大地降低时间复杂度

代码如下:

#include<cstdio>
int HashTable[100010]={0}; 
int main(){
	int n;
	scanf("%d",&n);
	int in[n];
	int ans=-1;
	for(int i=0;i<n;i++){
		scanf("%d",&in[i]);
		HashTable[in[i]]++;//如果只出现一次那就是1,如果出现重复的就++ 
	}
	for(int i=0;i<n;i++){
		if(HashTable[in[i]]==1){//没有重复值
		   ans=in[i]; 
		   break;
		}
	}
	if(ans<0) printf("None");
	else printf("%d",ans);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值