the k-th GCD(数论,最大公因数,和因子)

In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least one of them is not zero), is the largest positive integer that divides the numbers without a remainder.

—Wikipedia

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y.
InputThe first line contains a single integer T, indicating the number of test cases.

Each test case only contains three integers X, Y and K.

[Technical Specification]

  1. 1 <= T <= 100

  2. 1 <= X, Y, K <= 1 000 000 000 000

OutputFor each test case, output the k-th GCD of X and Y. If no such integer exists, output -1.Sample Input
3
2 3 1
2 3 2
8 16 3
Sample Output
1
-1
2
题意:求x与y的最大公约数的第k大的因子;
解题思路:首先求出x与y的最大公约数,然后再求最大公约数的所有因子,然后有顺序的储存在一个数组中,然后取出第k大的因子即可,如果k大于所有的因子数,那么输出-1就可以了。

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
#define maxn 100005
long long a[maxn],num;
long long gcd(long long a,long long b)
{
    return b==0?a:gcd(b,a%b);
}
void yz(long long n)
{
    num=0;
    long long i;
    for(i=1;i*i<n;i++)
        {
            if(n%i==0)
                {
                    a[num]=i;
                    num++;
                    a[num]=n/i;
                    num++;
                }
        }
    if(i*i==n) a[num]=i,num++;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
        {
            memset(a,0,sizeof(a));
            long long x,y,k;
            cin>>x>>y>>k;
            long long n=gcd(x,y);
            yz(n);
            if(k>num) cout<<-1<<endl;
            else
                {
                    sort(a,a+num);
                    cout<<a[num-k]<<endl;
                }
        }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值