寒假集训_专题四题解_E - Revenge of GCD

题目

In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least one of them is not zero), is the largest positive integer that divides the numbers without a remainder.
—Wikipedia

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y.
Input
The first line contains a single integer T, indicating the number of test cases.

Each test case only contains three integers X, Y and K.

[Technical Specification]

  1. 1 <= T <= 100
  2. 1 <= X, Y, K <= 1 000 000 000 000
    Output
    For each test case, output the k-th GCD of X and Y. If no such integer exists, output -1.
    Sample Input
    3
    2 3 1
    2 3 2
    8 16 3
    Sample Output
    1
    -1
    2

题目大意

求x、y最大公因数的第k大因子

题解

最大公因数可用gcd求,因为因子是成对出现的(t与x/t),求出之后遍历1~sqrt(gcd(x,y)),另一半用x除以得到的数。

代码

#include <iostream> 
#include <cmath>
using namespace std;
typedef long long LL;
const int N = 1e6+ 10;
LL ans[N],cnt;
LL gcd(LL a, LL b)
{
	if(a == b||b == 0)return a;
	return gcd(b,a%b);
}
int main()
{
	int t;
	cin >> t;
	while(t--)
	{
		LL a,b,k;
		cin >> a >> b >> k;
		LL x = gcd(a,b);
		cnt = 0;
		int t = sqrt(x);
		for(int i = 1; i <= t; i ++)
			if(x % i == 0)ans[++cnt] = i;
		int len = cnt;
		if(t*t == x)len--;
		if(k > len + cnt)printf("-1\n");
		else if(k <= len)printf("%lld\n",x/ans[k]);
		else printf("%lld\n",ans[len+cnt-k+1]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值