Cyclic Nacklace(next数组,最小循环节)

5 篇文章 0 订阅

Cyclic Nacklace

题目链接
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of “HDU CakeMan”, he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl’s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls’ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet’s cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a’ ~‘z’ characters. The length of the string Len: ( 3 <= Len <= 100000 ).

第一行是一个整数 T ( 0<T<=100 ) 代表测试数据的组数。
之后T行每行一个字符串,由小写字母组成,字符串的长度3<=L<=100000。

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
每组数据输出一行结果。

Sample Input

3
AAA
ABCA
ABCDE

Sample Output

0
2
5

题目分析

题目就是让你判断在后面加几个字符,能使其变循环拥有周期性,此题用到最小循环节的定义,
最小循环节长度=字符串长度-Next[字符串长度]; cnt=len-Next[len]
AAA的Next数组为 -1 0 1 2 最小循环节长度cnt=3-Next[3]=3-2=1
ABCA的Next数组为-1 0 0 0 1 最小循环节长度cnt=4-Next[4]=4-1=3
ABCDE的Next数组为 -1 0 0 0 0 0 最小循环节长度cnt=5-Next[5]=5-0=5
如果想了解就点一下下面的链接
最小循环节

代码实现

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<map>
#include<set> 
#include<string>
#include<stack>
#include<queue>
#include<vector>
#include<math.h> 
using namespace std;
typedef long long int ll;
char a[100005];
int Next[100005];
int len;
void getnext(char *a)
{
	int i=0,j=-1; 
	Next[0]=-1;
	while(i<len)
	{
		if(j==-1||a[i]==a[j])
		{
			Next[++i]=++j;
		}
		else
			j=Next[j];
	}
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		scanf("%s",a);
		len=strlen(a);
		getnext(a);
		int cnt=len-Next[len];          //最小循环节长度
		if(cnt!=len && len%cnt==0)		//本身存在循环len%cnt==0
		//或者if(Next[len]>0 && len%cnt==0)
			cout<<0<<endl;
		else							//本身无循环,如果本身无部分循环cnt就为len本身
			cout<<cnt-Next[len]%cnt<<endl;
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值