PAT A 1069 The Black Hole of Numbers (20 分)/B 1019 数字黑洞 (20 分)

75 篇文章 0 订阅

PAT A 1069 The Black Hole of Numbers (20 分)/B 1019 数字黑洞 (20 分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,10^ ​4​​ ).

Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000

B 1019 数字黑洞 (20 分) 中文题目:
给定任一个各位数字不完全相同的 4 位正整数,如果我们先把 4 个数字按非递增排序,再按非递减排序,然后用第 1 个数字减第 2 个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的 6174,这个神奇的数字也叫 Kaprekar 常数。

例如,我们从6767开始,将得到

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
现给定任意 4 位正整数,请编写程序演示到达黑洞的过程。

输入格式:
输入给出一个 (0,10^ 4​​ ) 区间内的正整数 N。

输出格式:
如果 N 的 4 位数字全相等,则在一行内输出 N - N = 0000;否则将计算的每一步在一行内输出,直到 6174 作为差出现,输出格式见样例。注意每个数字按 4 位数格式输出。

输入样例 1:
6767
输出样例 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
输入样例 2:
2222
输出样例 2:
2222 - 2222 = 0000
以下是AC的代码:

#include<cstdio>
#include<algorithm>
using namespace std;
const int len = 4;
const int blackhole=6174;
int num[len]={0};

void change2array(int n){//将数字转化为数组的函数; 
	for(int i=0;i<len;i++){
		num[i] = n % 10;
		n/=10;
	}
}
int change2num(){
	int ans=0;
	for(int i=0;i<len;i++){
		ans=ans*10+num[i];
	}
	return ans;
}
bool cmpmax(int a,int b){
	return a>b;
}
int main(void){
	int n;
	scanf("%d",&n);
	while(true){
		change2array(n);
		sort(num,num+len);
		int MIN = change2num();
		sort(num,num+len,cmpmax);
		int MAX = change2num();
		n=MAX-MIN;
		printf("%04d - %04d = %04d\n",MAX,MIN,n);
		if(n==0||n==blackhole) break;
	}
	return 0;
}

思路:
使用一个函数将输入的数字每一位存储到数组中,进行排序,再用一个函数将数组转化为数字,可以得到最大数字和最小数字,相减得到下一次需要处理的数字,判断其为0或者 6174 时退出循环。
这里需要注意循环至少要执行一次,因为如果输入数字是6174,或者是0,还是得输出一列。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值