kmp算法个人理解

关于kmp算法个人总结

定义一个next数组,求出待匹配部分最长相等前后缀,令next[0]=-1,然后累加,每加一个,看在它之前有多少个前后缀相等的部分,如果有,next[i]加一,否则,还等于之前那个数值。
拿一个实际题目来举例

例如 1 2 3 1 3

next[0]=-1

到1 2
之前的数为 1
next[1]=0

到1 2 3
之前的数为 1 2
前缀 1 后缀 2
没有相等的部分,所以值为0
next[2]=0

到 1 2 3 1
前面的数为1 2 3
前缀 {1,1 2} 后缀{3,2 3}
没有相等的部分,值为0
next[3]=0

到1 2 3 1 3
前面的数为1 2 3 1
前缀{1,1 2,1 2 3} 后缀{1,3 1,2 3 1}
有相等的前后缀1
next[4]=1

由此可见待匹配部分最长相等前后缀长度为1

求出next数组以后,再和需要去匹配的部分进行比对,如果全部匹配成功,贼返回匹配成功的字符串下标,不匹配贼返回-1

以Number Sequence为例

Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1

代码如下:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
#define IOS                      \
    ios::sync_with_stdio(false); \
    cin.tie(0)

// *start on @date: 2021-04-27 21:40
ll a[1000001];
ll b[10001];
ll next1[10001];
ll num, k, m, n;
void getnext()
{
    k = 0;
    num = -1;
    next1[0] = -1;
    while (k < m - 1)
    {
        if (num == -1 || b[k] == b[num])
        {
            k++;
            num++;
            next1[k] = num;
        }
        else
        {
            num = next1[num];
        }
    }
}
int kmp()
{
    int i=0, j=0;
    getnext();
    while (i < n && j < m)
    {
        if (j == -1 || a[i] == b[j])
        {
            i++;
            j++;
        }
        else
        {
            j = next1[j];
        }
    }
    if (j >=m)
    {
        return (i - m);
    }
    else
    {
        return (-1);
    }
}
int main()
{
    IOS;
    bool flag;
    int t;
    cin >> t;
    for (int i = 0; i < t; i++)
    {
        cin >> n >> m;
        next1[0] = -1;
        for (ll j = 0; j < n; j++)
        {
            cin >> a[j];
        }
        for (ll j = 0; j < m; j++)
        {
            cin >> b[j];
        }
        int h = kmp();
        if (h!=-1)
        {
            cout << h+1 << endl;
        }
        else
        {
            cout << "-1" << endl;
        }
    }
    return 0;
}
  • 4
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值