Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9].
[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent’s signs are always provided even when they are positive.
Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.
Input Specification:
Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent’s absolute value is no more than 9999.
Output Specification:
For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.
Sample Input 1:
+1.23400E-03
Sample Output 1:
0.00123400
Sample Input 2:
-1.2E+10
Sample Output 2:
-12000000000
Ω
科学计数法转常规数字,无需去除尾数0降低了些难度,只需要记住小数点的位置即可。
注意到题目给出的科学计数法正则表达式为 ,说明在小数点前永远是【符号位+一个数字】。那么先把其中E前底数去掉符号位和小数点单独取出,然后读取E后面的指数 ( ),如果假设首个数字索引为0,那么小数点就在第 个数字前面。而最后我们需要输出的数字索引范围即为 ,注意如果小数点在第一个数字前面就需要把前置0也输出因此 ,超出数字个数则需要把尾0补上。
🐎
#include <iostream>
using namespace std;
int main()
{
string s, n;
cin >> s;
int point;
for (int i = 1; i < int(s.size()); ++i)
{
if (isdigit(s[i]))
n += s[i];
else if (s[i] == 'E')
{
point = 1 + stoi(s.substr(i + 1));
break;
}
}
cout << (s[0] == '+' ? "" : "-");
for (int i = min(point - 1, 0); i < max(point, int(n.size())); ++i)
{
cout << (i == point ? "." : "");
if (i < 0 || i >= int(n.size()))
cout << '0';
else
cout << n[i];
}
}