「1024」Palindromic Number

➳ENTRY

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤ ) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

Ω

极简翻译,给定一个 以内的正整数N和一个100以内的整数K,在K次循环内,如果N是一个回文数就退出并输出该回文数和相应的次数,否则将该数的逆序数加上N再赋值给N。若K次之后N还不是回文数,则输出当前N与K。

乍一看,so easy。虽然说,N最大是11位,有可能超出int的范围,那我换个long long int不就完事了。小手一点,有两个绿的。干,忘记考虑运算过程中的N了。考虑极端情况,如果N是一个11位数K取20而且每次和逆序数相加都会增加一位,那么K次之后N早就超出100位了。好吧,回归字符串。

我们只需实现两个字符串大数的相加即可,非常easy不赘述了。每次循环开始的时候判断一下N是否是回文串,是则退出循环。


C ☺ D E

#include <iostream>
#include <algorithm>

using namespace std;

inline bool isPalindromic(string s)
{
    string r = s;
    reverse(r.begin(), r.end());
    return s == r;
}

string addReverse(string &s)
{
    int len = s.size(), flag = 0, single;
    string otc = "";
    for (int i = 0; i < len; ++i)
    {
        single = (s[i] - '0') + (s[len - 1 - i] - '0') + flag;
        otc = to_string(single % 10) + otc;
        flag = single / 10;
    }
    if (flag)
        otc = to_string(flag) + otc;
    return otc;
}

int main()
{
    string n;
    int k, i;
    cin >> n >> k;
    for (i = 0; i < k && !isPalindromic(n); ++i)
        n = addReverse(n);
    cout << n << endl << i << endl;
}

reverse函数可以直接在容器内实现逆序,还挺神奇。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值